I report NMC non riescono a generare, errore "Connection Refused. verificare che il nome host e la porta siano corretti e che il portmaster accetti le connessioni TCP/IP" viene visualizzato

Riepilogo: Si sta tentando di generare report in NetWorker Management Console (NMC) e si riceve: "Connessione rifiutata. verificare che il nome host e la porta siano corretti e che il portmaster accetti le connessioni TCP/IP". ...

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Si sta tentando di generare report in NetWorker Management Console (NMC) e si riceve: 
"Connessione rifiutata. verificare che il nome host e la porta siano corretti e che il portmaster accetti le connessioni TCP/IP"
kA2f1000000K6b7CAC_3_0
 

Causa

La porta 5432 non è aperta o è bloccata tra il client NMC e il server NetWorker/NMC.

Risoluzione

1. Sul server NMC, verificare che la porta 5432 sia in ascolto:
Linux: netstat -anop | grep 5432
Windows: netstat -ao | findstr 5432
C:\Windows\system32>netstat -ao | findstr 5432
  TCP    0.0.0.0:5432           WINSRVR2K16:0          LISTENING       2836
  TCP    127.x.x.1:5432         WINSRVR2K16:49380      ESTABLISHED     2836
  TCP    127.x.x.1:49380        WINSRVR2K16:5432       ESTABLISHED     3556
  TCP    [::]:5432              WINSRVR2K16:0          LISTENING       2836
  UDP    127.x.x.1:65432        *:*                                    724
2. Sul client NMC, verificare che la porta 5432 sia raggiungibile sull'host del server NMC:
Sintassi: nsrports -t NMC_Server_Hostname -p 5432
C:\Users\Administrator>nsrports -t winsrvr2k16 -p 5432
Forward lookup for winsrvr2k16
Query time:              0.001 sec
Canonical name (CNAME):  winsrvr2k16.lab.emc.com
Address (A):             192.xxx.xx.xx
Connect to port 5432:    . . . . . . * 
A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.


Reverse lookup for 192.xxx.xx.xx
Query time:              0.003 sec
Name:                    winsrvr2k16.lab.emc.com

3. Verificare che non vi siano firewall del sistema operativo o di rete che blocchino la porta 5432, una volta aperto il comando precedente:
C:\Users\Administrator>nsrports -t winsrvr2k16 -p 5432
Forward lookup for winsrvr2k16
Query time:              0.001 sec
Canonical name (CNAME):  winsrvr2k16.lab.emc.com
Address (A):             192.xxx.xx.xx
Connect to port 5432:    Succeeded (0.007 sec)

Reverse lookup for 192.xxx.xx.xx
Query time:              0.000 sec
Name:                    winsrvr2k16.lab.emc.com

Informazioni aggiuntive

Prodotti interessati

NetWorker

Prodotti

NetWorker
Proprietà dell'articolo
Numero articolo: 000038109
Tipo di articolo: Solution
Ultima modifica: 06 nov 2025
Versione:  6
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.