VxRail: vCenter segnala capacità VSAN errata

Riepilogo: vCenter segnala un utilizzo non corretto della capacità VSAN

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Quando si controlla la capacità VSAN dal vSphere Web Client, la capacità VSAN mostrata è inferiore alla capacità VSAN prevista. RVC mostra la capacità VSAN corretta.

In questo caso, ogni nodo disponeva di unità con capacità di 3-1 TB, per un totale di ~13 TB di capacità VSAN totale. vSphere Web Client mostrava ~9 TB come indicato di seguito:
Capacità su vSphere Web Client

Da RVC:

/localhost/MARVIN-Datacenter/datastores> ls
1 MARVIN-Virtual-SAN-Datastore-0385aed5-ddae-42f7-aab2-8fe5f992c9b9: 14258.75GB

 

Causa

Uno degli host nel cluster credeva di essere ancora in modalità di manutenzione. Non veniva visualizzato in modalità di manutenzione in vCenter, ma l'output riportato di seguito mostrava che era in modalità di manutenzione:

Dall host esx, eseguire il seguente comando.

cmmds-tool find -f python

E controllare il decomState:

{
   "uuid": "57908981-beff-abdf-f76d-001e67dc4fc0",
   "owner": "57908981-beff-abdf-f76d-001e67dc4fc0",
   "health": "Healthy",
   "revision": "6",
   "type": "NODE_DECOM_STATE",
   "flag": "2",
   "minHostVersion": "0",
   "md5sum": "7c88fc7eea9891e32bc7b35532085ee5",
   "valueLen": "80",
---> looks like we're decommissioned due to Maintenance Mode:
   "content": "{\"decomState\": 6, \"decomJobType\": 1, \"decomJobUuid\": \"00000000-0000-0000-0000-000000000000\", \"progress\": 0, \"affObjList\": [ ], \"errorCode\": 0, \"updateNum\": 0, \"majorVersion\": 2}",
   "errorStr": "(null)"
},

Possibili cause di questo problema:

  1. L'eliminazione di un gruppo di dischi senza il passaggio del nodo alla modalità di manutenzione può portare un nodo in questo stato. Questo non causerebbe questo problema, ma occasionalmente può verificarsi.
  2. Una manutenzione non riuscita con migrazione completa dei dati potrebbe causare questo problema. In genere, sono gli oggetti inaccessibili e orfani che possono causare l'errore di un host che entra in modalità di manutenzione (MM).
  3. Questo problema potrebbe essere causato dalla disunione e dalla reaggiunta di un nodo dal cluster VSAN.

 

Risoluzione

Impostare l'host in modalità di manutenzione (Ensure Accessibility), quindi, una volta che l'host è in modalità di manutenzione, uscire dalla modalità di manutenzione.
Al termine di questa operazione, la capacità VSAN dovrebbe essere visualizzata correttamente in vSphere Web Client.

 

Prodotti interessati

VxRail Appliance Family

Prodotti

VxRail Appliance Family
Proprietà dell'articolo
Numero articolo: 000052308
Tipo di articolo: Solution
Ultima modifica: 17 apr 2026
Versione:  6
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.