RecoverPoint:升級在系統診斷時失敗

Riepilogo: 升級在系統診斷時失敗,因為 ISO 無效

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

從 5.1 至 5.1 SP4

的升級 由於 ISO 無效,在系統診斷步驟使用 DM 從 5.1 至 5.1 SP4 的升級失敗。

在記錄中找到的症狀:

InstallationLogs /server.cli 中的

錯誤:2020-01-12 08:55:04,930 [CommandWorker-1] (Command.java:403) WARN-ExternalProcess[[/home/kos/kbox/src/installation/distribution/iso_services.sh get_tweak_param /home/kos/iso/rel5.1.SP4_h.81_release_emc_RP.iso tweak.params.version t_extVersionVisibleString tweak.params.installation_tools t_supportedToolVersion tweak.params.installation_tools t_lastMajorVersion tweak.params.scsi_initiator t_unsupportedClariionVersionsForRPSE ]]ErrorStream=/home/kos/kbox/src/installation/distribution/iso_services.sh starting.....( get_tweak_param /home/kos/iso/rel5.1.SP4_h.81_release_emc_RP.iso tweak.params.version t_extVersionVisibleString tweak.params.installation_tools t_supportedToolVersion tweak.params.installation_tools t_lastMajorVersion tweak.params.scsi_initiator t_unsupportedClariionVersionsForRPSE )
掛接:/dev/loop0 為寫保護,掛接唯讀

DM 記錄中的錯誤:

2020-01-12 02:55:17,421 [ModalContext] (GetTweaksFromISOFileCommand.java:78) ERROR - getTweaksFromISOFile 失敗 - 從 ISO 取得調整失敗。 tweaksRV=ReturnValue [_isSuccess=false, _message=Failed 取得 tweak 值,收到錯誤: error: tweak 檔案 'tweak.params.version' 不存在, _data=null, _throwable=com.emc.dm 例外。InstallationFlowException:取得 tweak 值失敗,收到錯誤:錯誤:tweak 檔案 'tweak.params.version' 不存在,_failureReason=UNKNOWN] com.emc.dm 例外。InstallationFlowException:取得 tweak 值失敗,收到錯誤:錯誤:tweak 檔案 'tweak.params.version' 不存在

在 DM 記錄中,dm.properties 檔案中的SHOULD_CHECK_ISO_CHECKSUM似乎設為 false。由於錯誤的布林值,因此無法在上傳的 ISO 上執行檢查總和:

2020-01-12 02:21:22,794 [pool-1-thread-17] (ValidateISOAfterDownloadCommand.java:25) DEBUG - 未取得 ISO 校驗和。

Causa

DM 無法在上傳 iso 時驗證檢查總和,並繼續檢查系統診斷步驟,
這是因為 dm.properties 檔案中有一個名為 SHOULD_CHECK_ISO_CHECKSUM 的屬性,而此屬性是將布林屬性設為 false。(預設值應為 true)
所建立的 isoVerified 檔案,在 iso 通過檢查總和之前,不應建立該檔案。

Risoluzione

解決方案:

這個問題有解決方案,但必須由 Dell EMC 技術支援人員介入,請聯絡 Dell EMC 客戶支援中心或您的服務代表以取得技術協助,並引用此 Dell EMC 知識庫解決方案 ID。

Informazioni aggiuntive


 

Prodotti interessati

RecoverPoint EX

Prodotti

RecoverPoint CL, RecoverPoint EX, RecoverPoint SE
Proprietà dell'articolo
Numero articolo: 000063459
Tipo di articolo: Solution
Ultima modifica: 14 nov 2025
Versione:  4
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.