Dosya Sistemi için SourceOne - Isilon SMB paylaşımı için "listeye ekleme" işlemi başarısız olduğunda dosyaları geri yükleme

Riepilogo: SourceOne-for-File-System-Restoring-files-using-add-to-restore-list-failed-for-Isilon-SMB-share

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi



Dosyaları "geri yükleme listesine ekle" seçeneğini kullanarak geri yükleme işlemi Isilon SMB paylaşımında bulunan dosyalar için başarısız olurken Windows paylaşım klasörlerinde bulunan dosyalar için çalışıyor.

ExJBRestore'da aşağıdaki hatalar gösterilir:
CExFileSystem::iWriteFileProperties|
VERBOSE|
iWriteFileProperties calling ::CreateDirectory with perm for \\?\UNC\SMBPath\sourceone_test\|

CExFileSystem::iWriteFileProperties|
VERBOSE|
Checking that user 'SourceOneServiceAccount' has write permissions to the directory '\\\?\UNC\SMBPath\sourceone_test\'|

CExFileSystem::iWriteFileProperties|
ERROR|
Error encountered checking permissions (0x80072147)|

CoExFileProvider::StoreDoc|
ERROR|
Failed to restore file to original location (MessageID). (0x86044701) The specified property 20 does not exist (0x86044002)|

CExRestoreThread::ProcessRun|
WARNING|
Failed restore item: Unable to verify that the user has required file system permissions to restore the file.  Try restoring to an alternate location. (0x86044710)|

CExRestoreThread::ProcessRun|
ERROR|
CExRestoreThread failed msgid: MessageID result hr=86044710|


 

Causa

OneFS'ye bağlanın ve SMB paylaşımını kontrol edin. SourceOne paylaşımında SourceOne hizmet hesabı kullanıcısı yok. Hizmet hesabının orada olması gerekir.
Bunun nedeni, Isilon tarafında SourceOne Hizmet hesabı için izin verilmemesidir. Isilon'un kimlik doğrulama için bir referans noktasına ihtiyacı vardır; bu referans noktası LDAP, NIS veya yerel kullanıcılar olabilir. Tanınması için UID'ler hakkında bir kaynağa sahip olması gerekir.

Risoluzione

OneFS'ye bağlanın. SourceOne hizmet hesabı için kullanıcı yoksa, aşağıdaki prosedürü kullanarak oluşturmanız gerekir:

SourceOne kullanıcısını oluşturma adımları:
1- OneFS'nizden "Erişim"e gidin ve ardından "Üyelik ve Roller"
e tıklayın2- Geçerli Erişim Bölgesini seçin: Sistem
3- "Kullanıcı" sekmesine tıklayın ve ardından sağlayıcınızı seçin: "YEREL: Sistem"
4- Sağ tarafta bulunan Create a User (Kullanıcı Oluştur) seçeneğine tıklayın.
OneFS arabirimi 
5- Aşağıdakileri doldurun:
Kullanıcı adı: service Account name"
Password: service account password"
Full Name: SourceOne Hizmet Hesabı
Birincil Grubu: --->Select group ögesine tıklayın, ardından Provider "LOCAL:system" öğesini seçin ve aramayı başlatın. Burada "Isilon Kullanıcıları"nı seçin, Kullanıcı Oluştur'a
tıklayın.
Kullanıcıları yönet ekranı 
6- Kullanıcıyı

etkinleştirin Şimdi bu kullanıcıyı SMB Paylaşımına eklemeniz gerekir:
1- Protokol'e ve ardından SMB Paylaşımı'na gidin.
2- Geçerli Erişim Bölgesini seçin: Sistem
3- SourceOne SMB Paylaşımınızda, Düzenle
4- Kullanıcıları ve grupları düzenle yi seçin ve ardından"Kullanıcı veya Grup ekle" seçeneğini belirleyin. Yerel: sistem sağlayıcısını seçtiğinizde önceden oluşturulmuş SourceOne hizmet hesabını bulursunuz. Tam izin verin ve kullanıcıyı ekleyin. Hizmet hesabını ilk sıraya koyun ve kaydedin.
5- Artık OneFS Side'dan izinler iyi
OneFS arabirimi 

Prodotti interessati

SourceOne for File Systems

Prodotti

SourceOne for File Systems
Proprietà dell'articolo
Numero articolo: 000064614
Tipo di articolo: Solution
Ultima modifica: 27 giu 2025
Versione:  3
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.