SourceOne для файловой системы: Не удалось восстановить файлы с помощью команды «добавить в список восстановления» для общего ресурса SMB Isilon

Riepilogo: SourceOne-for-File-Restoring-files-using-add-to-restore-list-failed-for-Isilon-SMB-share

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi



Восстановление файлов с помощью команды «добавить в список восстановления» не работает для файлов, расположенных в общем ресурсе Isilon SMB, но работает для файлов, расположенных в папках общего ресурса Windows.

В ExJBRestore отображаются следующие ошибки:
CExFileSystem::iWriteFileProperties|
VERBOSE|
iWriteFileProperties calling ::CreateDirectory with perm for \\?\UNC\SMBPath\sourceone_test\|

CExFileSystem::iWriteFileProperties|
VERBOSE|
Checking that user 'SourceOneServiceAccount' has write permissions to the directory '\\\?\UNC\SMBPath\sourceone_test\'|

CExFileSystem::iWriteFileProperties|
ERROR|
Error encountered checking permissions (0x80072147)|

CoExFileProvider::StoreDoc|
ERROR|
Failed to restore file to original location (MessageID). (0x86044701) The specified property 20 does not exist (0x86044002)|

CExRestoreThread::ProcessRun|
WARNING|
Failed restore item: Unable to verify that the user has required file system permissions to restore the file.  Try restoring to an alternate location. (0x86044710)|

CExRestoreThread::ProcessRun|
ERROR|
CExRestoreThread failed msgid: MessageID result hr=86044710|


 

Causa

Подключитесь к OneFS и проверьте общий ресурс SMB. В общем ресурсе SourceOne нет пользователя сервисной учетной записи SourceOne. Там должна быть сервисная учетная запись.
Это вызвано отсутствием разрешения на стороне Isilon для учетной записи службы SourceOne. Для аутентификации Isilon требуется точка отсчета: это могут быть пользователи LDAP, NIS или локальные пользователи. Для его распознавания должен быть источник в UID.

Risoluzione

Подключитесь к OneFS. Если у сервисной учетной записи SourceOne нет пользователя, необходимо создать ее с помощью следующей процедуры:

Шаги для создания пользователя SourceOne:
1- В OneFS перейдите в раздел «Доступ», а затем нажмите «Членство и роли»
2- Выберите текущую зону доступа: Система 3- Перейдите на вкладку «Пользователь
» и выберите поставщика: «МЕСТНЫЙ: Система"
4- Нажмите Создать пользователя справа.
Интерфейс OneFS 
5- Заполните следующее:
Имя пользователя: "service Account name"
Пароль: "Пароль сервисной учетной записи"
Полное имя: Основная группа сервисной учетной записи
SourceOne: --->Нажмите выбрать группу, затем выберите поставщика "LOCAL:system" и начните поиск. Здесь выберите «Пользователи Isilon»
Нажмите «Создать пользователя».
Экран «Управление пользователями» 
6. Включите пользователя

Теперь необходимо добавить этого пользователя в общий ресурс SMB:
1- Перейдите к протоколу, а затем к общему ресурсу SMB.
2. Выберите текущую зону доступа: Система
3 — в общем ресурсе SourceOne SMB выберите Изменить
4 — Изменить пользователей и группы, а затем выберите«Добавить пользователя или группу». Выберите поставщика системы Local:, и вы увидите сервисную учетную запись SourceOne, созданную ранее. Дайте полное разрешение и добавьте пользователя. На первом месте укажите сервисную учетную запись и сохраните ее.
5- Теперь разрешение в порядке со стороны OneFS
Интерфейс OneFS 

Prodotti interessati

SourceOne for File Systems

Prodotti

SourceOne for File Systems
Proprietà dell'articolo
Numero articolo: 000064614
Tipo di articolo: Solution
Ultima modifica: 27 giu 2025
Versione:  3
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.