Data Protection Advisor: Agent fails to register with the server

Riepilogo: Data Protection Agent (DPA) fails to register with Data Protection Application (DPA APP) server due to Hyper-Text Transfer Protocol (HTTP) proxy setting, resulting in Communication Url (CURL) error [56] and Hyper-Text Transfer Protocol (HTTP) code 403. ...

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Agent does not show in the UI under Data Collection>Agents, even though the agent is installed.

With the agent set to debug find the following displays in the agent log:
 

DBG1    18535.18535    20170628:142552             com.http - httpSendRequest(): CURL error: [56] Received HTTP code 403 from proxy after CONNECT
ERR     18535.18535    20170628:142552         agent.config - initAgentConfig(): Failed to register agent with the server. Waiting to retry...


 

Causa

An http proxy setting causes this issue which leads the DPA APP server to reject agent registration request upon connection.

Risoluzione

Log in to the DPA agent server as root do the following:

Stop the DPA agent service with the following command:

/opt/emc/dpa/agent/etc/dpa stop


Edit the dpa.custom file, found in the <DPA install directory>/dpa/agent/etc directory and add the following two lines:
 

export http_proxy=
export https_proxy=
 
The above two lines should be created exactly as above without any further characters beyond the =.


Save the changes and restart the agent service. The agent should register now, as the new entries in the dpa.custom file unsets any operating system level http or https proxy settings. 

Contact Dell Technical Support for additional information.

 

Prodotti

Data Protection Advisor
Proprietà dell'articolo
Numero articolo: 000065495
Tipo di articolo: Solution
Ultima modifica: 18 apr 2026
Versione:  5
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.