Přírůstkové zálohování RCT Avamar Hyper-V selhává s chybou "Failed to get RCT extents for the disk file" nebo "Reference point creation for Virtual machine failed"
Riepilogo: Článek znalostní báze (KB) s podrobnostmi o opravách hotfix, které řeší selhání zálohování technologie Hyper-V Resilient Change Tracking (RCT) z důvodu rozsahu RCT.
Questo articolo si applica a
Questo articolo non si applica a
Questo articolo non è legato a un prodotto specifico.
Non tutte le versioni del prodotto sono identificate in questo articolo.
Sintomi
Přírůstkové zálohování RCT Avamar Hyper-V u některých virtuálních počítačů selhává s chybou "Failed to get RCT extents for the disk file"
Zde je fragment z protokolu zálohování:
V protokolech aplikace systému Windows, systému a prohlížeče událostí technologie Hyper-V se nezobrazuje žádné varování ani chybová zpráva.
Chyba "Reference point creation for Virtual machine" se zobrazuje pouze v protokolech Avamar.
Zde je relevantní část z winclustersvc.log:
Zde je fragment z protokolu zálohování:
2019-07-08 23:44:41 avhypervvss Error <43426>: Checkpoint creation for Virtual machine '<VM_NAME>'<VM_GUID>' has failed and will be skipped from backup. For details, please check 'winclustersvc.log'. 2019-07-08 23:44:41 avhypervvss Error <43940>: Failed to get the RCT extents for Virtual machine '<VM_NAME>'<VM_GUID>' and will be skipped from backup. For details, please check 'winclustersvc.log'.V souboru winclustersvc.log (umístěném ve složce Avamar VAR na primárním uzlu Hyper-V):
2019-07-08 23:44:35 winclustersvc ERROR<0000>: Failed to get RCT extents for the disk file C:\ClusterStorage\<VM_PATH_TO_VHDX>: Failed to get the disk information.Zálohování také může selhat s níže uvedenou chybou:
"Reference point creation for Virtual machine '<VM_NAME>'<VM_GUID>' has failed".Jeden z uzlů clusteru je hostitelem dotčených virtuálních počítačů.
V protokolech aplikace systému Windows, systému a prohlížeče událostí technologie Hyper-V se nezobrazuje žádné varování ani chybová zpráva.
Chyba "Reference point creation for Virtual machine" se zobrazuje pouze v protokolech Avamar.
Zde je relevantní část z winclustersvc.log:
2019-06-25 18:19:41 winclustersvc DEBUG<0000>: Affected VM Path is \\<Hyperv_Node>\root\virtualization\v2:Msvm_ComputerSystem.CreationClassName="Msvm_ComputerSystem",Name="<.....>" 2019-06-25 18:19:41 winclustersvc DEBUG<0000>: ===> ValidateJobOutput 2019-06-25 18:27:09 winclustersvc DEBUG<0000>: <=== ValidateJobOutput 2019-06-25 18:27:09 winclustersvc ERROR<0000>: Exception in validateTargetMergeStatus: Not found . 2019-06-25 18:27:10 winclustersvc ERROR<0000>: Exception in validateTargetMergeStatus: Not found . 2019-06-25 18:27:10 winclustersvc DEBUG<0000>: ResilientChangeTrackingIdentifiers rctid :rctX:917dbfe9:0da5:4fda:8d9f:34cdc6cf85b8:00000002 2019-06-25 18:27:10 winclustersvc DEBUG<0000>: VirtualDiskIdentifiers vmid :Microsoft:<................> 2019-06-25 18:27:10 winclustersvc DEBUG<0000>: Affected VM Path is \\<Hyperv_Node>\root\virtualization\v2:Msvm_ComputerSystem.CreationClassName="Msvm_ComputerSystem",Name="<......>" 2019-06-25 18:27:10 winclustersvc DEBUG<0000>: ===> ValidateJobOutput 2019-06-25 18:27:10 winclustersvc DEBUG<0000>: <=== ValidateJobOutput 2019-06-25 18:27:10 winclustersvc INFO<0000>: Exception in reference point creation for vm group 'AvamarBackup_<........>' : Not found 2019-06-25 18:27:10 winclustersvc INFO<0000>: Reference point conversion failed for vm <VM_NAME>.. . . 2019-06-25 18:27:10 winclustersvc DEBUG<0000>: ===> SerializeHypervVMList. 2019-06-25 18:27:10 winclustersvc DEBUG<0000>: <=== SerializeHypervVMList. 2019-06-25 18:27:10 winclustersvc INFO<0000>: ----------------------End [EMC Avamar Plug-in Service for Windows] log ------------------- 2019-06-25 20:15:08 winclustersvc INFO<0000>: Cleaning up checkpoint created on group AvamarBackup_<........> 2019-06-25 20:15:08 winclustersvc WARN<0000>: Failed to execute DestroySnapshot method: The method call failed.. 2019-06-25 20:15:08 winclustersvc INFO<0000>: Cleaning up checkpoint created on group AvamarBackup_<........> 2019-06-25 20:15:08 winclustersvc WARN<0000>: Failed to execute DestroySnapshot method: The method call failed.. 2019-06-25 21:31:32 winclustersvc INFO<0000>: Creating an alternate Log file : C:\ClusterStorage\<...>\var-share\temp_log.log 2019-06-25 21:31:32 winclustersvc INFO<0000>: Debug output enabled from Plug-in.Pokaždé, když je zálohování vynuceno k úplnému dokončení a na konci selže kvůli chybě referenčního bodu, virtuální počítač (VM) se vyloučí.
Causa
Modul plug-in VSS technologie Hyper-V původně používal obor názvů Hyper-V ve voláních rozhraní WMI k získání rozsahů RCT. U nových oprav hotfix byl kód změněn tak, aby místo toho odkazoval na obor názvů clusteru.
Risoluzione
Kumulativní opravy hotfix Avamar Hyper-V jsou vyžadovány pro starší verze doplňku. Zahrnují nejnovější změny kódu pro odolné sledování změn (RCT) pro vylepšení zálohování i obnovení.
Seznam nejnovějších kumulativních oprav hotfix modulu plug-in Hyper-V:
Chcete-li stáhnout opravy hotfix, přečtěte si část "Hledání opravy hotfix se znalostí čísla HF" v následujícím článku: Pokyny k instalaci oprav hotfix nebo upgradu na nejnovější verzi softwaru Avamar naleznete v následujícím článku znalostní databáze DELL:
Avamar: Modul plug-in VSS technologie Hyper-V – Konfigurace a instalace nejnovějších kumulativních oprav hotfix pro verzi 19.4 a vyšší
Seznam nejnovějších kumulativních oprav hotfix modulu plug-in Hyper-V:
- Zásuvný modul Avamar verze 19.4.100-124 HF 337285
- Zásuvný modul Avamar verze 19.7.100-82 HF 337450
- Zásuvný modul Avamar verze 19.8.100-83 HF 337654
Chcete-li stáhnout opravy hotfix, přečtěte si část "Hledání opravy hotfix se znalostí čísla HF" v následujícím článku: Pokyny k instalaci oprav hotfix nebo upgradu na nejnovější verzi softwaru Avamar naleznete v následujícím článku znalostní databáze DELL:
Avamar: Modul plug-in VSS technologie Hyper-V – Konfigurace a instalace nejnovějších kumulativních oprav hotfix pro verzi 19.4 a vyšší
Prodotti interessati
AvamarProprietà dell'articolo
Numero articolo: 000080002
Tipo di articolo: Solution
Ultima modifica: 07 ott 2024
Versione: 9
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.