I sistemi Precision o OptiPlex restituiscono errori "Errore durante l'allocazione della barra di memoria per il dispositivo PCI" durante il POST

Riepilogo: Questo articolo fornisce informazioni sull'errore "Errore durante l'allocazione della barra di memoria per il dispositivo PCI" visualizzato durante il POST sui sistemi OptiPlex e Precision. ...

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

I sistemi Precision o OptiPlex restituiscono errori "Errore durante l'allocazione della barra di memoria per il dispositivo PCI" durante il POST

Un utente può segnalare un errore durante la routine di Power On Self-Test (POST) su un sistema OptiPlex o Precision.

L'errore "Errore durante l'allocazione della Mem BAR per il dispositivo PCI" si verifica quando si tenta di utilizzare più schede PCI dello stesso tipo, incluse schede video, audio o di rete. Il sistema non è in grado di allocare DMA, indirizzi I/O o IRQ tra più dispositivi PCI/PCIe.

Causa

Possibili cause

Questo problema può essere causato da una delle seguenti cause:

  1. Un dispositivo difettoso
  2. Un problema del BIOS o della NVRAM
  3. Slot PCI o chipset difettoso sulla scheda madre

1. Un dispositivo difettoso

Una delle schede PCI potrebbe essere difettosa. Se possibile, sostituire ciascuna scheda una alla volta con una scheda funzionante verificata dello stesso tipo.

Verificare anche la presenza di aggiornamenti del firmware per la scheda, che di solito si trovano sul sito Web del produttore per la scheda in questione.


2. Un problema del BIOS o della NVRAM

Accertarsi che il sistema disponga della versione più recente del BIOS. Visitare il sito del supporto Dell e scaricare la versione più recente del BIOS per il sistema in uso.

Un'altra area che potrebbe causare questo problema è all'interno della NVRAM (Non-Volatile Random Access Memory) che memorizza le informazioni relative ai dispositivi installati sul sistema. Reimpostando la NVRAM, il sistema cerca nuovamente tutti i dispositivi e reinizializza le informazioni conservate in memoria.

Nota: Per ulteriori informazioni sulla cancellazione della NVRAM e sull'aggiornamento del BIOS, consultare l'articolo seguente: Come eseguire un ripristino del BIOS o del CMOS e cancellare la memoria NVRAM sui computer Dell

3. Uno slot PCI o un chipset difettoso sulla scheda madre

Un problema con uno slot PCI difettoso sulla scheda madre o un problema con il chipset.
Visitare il sito del supporto Dell e scaricare la versione più recente del chipset per il sistema in uso.

Per risolvere i problemi dello slot PCI sulla scheda madre, procedere come segue:

  1. Rimuovere tutte le schede PCI dal sistema.

  2. Selezionare una scheda, installarla nel primo slot e testare accendendo il sistema.

  3. Rimuovere la prima scheda e installarla nel secondo slot del sistema. Eseguire un test accendendo il sistema.

  4. Continuare spostando la scheda in ogni slot e testandone la funzionalità.

  5. Eseguire i controlli di cui sopra con ciascuna scheda.

  6. Se i risultati del test non sono definitivi, installare due schede e spostare ciascuna scheda in slot diversi ed eseguire il test dopo ogni permutazione.

Risoluzione

Se si scopre che uno degli slot PCI è effettivamente difettoso. Contattare il supporto tecnico Dell esponendo i risultati riscontrati e per ricevere consigli su come procedere.

Torna all'inizio

Prodotti interessati

Fixed Workstations
Proprietà dell'articolo
Numero articolo: 000137871
Tipo di articolo: Solution
Ultima modifica: 24 lug 2025
Versione:  7
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.