PowerEdge: iDRAC non visualizza correttamente il nome host ESXi e il sistema operativo

Riepilogo: Fornisce la procedura per compilare il nome host e il sistema operativo in iDRAC per i server che eseguono VMware ESXi 6.5 e versioni successive.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Gli utenti di iDRAC potrebbero notare che i server Dell EMC PowerEdge non riportano i campi relativi al nome host e al sistema operativo del sistema VMware ESXi 6.5 o 6.7 nelle interfacce web e CLI del controller iDRAC. Questo comportamento è diverso da quello precedentemente riscontrato nei server Dell EMC PowerEdge con VMware ESXi 6.0 e versioni precedenti. 




Immagine del nome host iDRAC e del nome host ESXi 

Causa

iDRAC non esegue il polling del nome host del sistema operativo. Il sistema operativo invia il nome host al controller iDRAC tramite provider CIM. In ESXi 6.0 il fornitore CIM è abilitato per impostazione predefinita. Questo comportamento è cambiato in ESXi 6.5. I fornitori CIM sono disabilitati per impostazione predefinita.

Risoluzione

Per risolvere questo problema, è necessario abilitare i fornitori CIM tramite ESXCLI e riavviare l'host.

esxcli system wbem set –e true
/etc/init.d/sfcbd-watchdog start

 Al termine del riavvio, aggiornare iDRAC e il nome host caricato dovrebbe essere aggiornato.

Schermata della corrispondenza dei nomi host ESXI e iDRAC  

Nelle build più recenti di ESXi 6.5 e 6.7, l'abilitazione wbem continuerà a non mostrare il nome host ESXi corretto in iDRAC. Ciò è dovuto a una modifica intenzionale di VMware in cui questa funzionalità (scrittura del nome host in BMC utilizzando provider CIM della posta in arrivo) è stata rimossa. L'intenzione futura è che il servizio hostd esegua questa funzione.

Se l'opzione è abilitata wbem (indicazioni elencate in precedenza) non risolvono il problema, si consiglia di installare Dell EMC iSM (iDRAC Service Module) o OpenManage Server Administrator vSphere Installation Bundle (VIB) per ESXi nel sistema operativo ESXi.

Prodotti interessati

iDRAC7, iDRAC8, iDRAC9, VMware ESXi 6.5.X, VMware ESXi 6.7.X, VMware ESXi 6.x, VMware ESXi 7.x

Prodotti

iDRAC Service Module, PowerEdge FC640, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX740C, PowerEdge MX840C, PowerEdge R240, PowerEdge R250, PowerEdge R340, PowerEdge R350, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550 , PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R840, PowerEdge R940, PowerEdge R940xa, PowerEdge T140, PowerEdge T150, PowerEdge T340, PowerEdge T350, PowerEdge T440, PowerEdge T550, PowerEdge T640 ...
Proprietà dell'articolo
Numero articolo: 000142904
Tipo di articolo: Solution
Ultima modifica: 04 dic 2024
Versione:  7
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.