「ハードウェア リソースのボトルネックが原因で仮想マシンのAvamarゲスト バックアップが遅くなりタイムアウトする(英語)」

Riepilogo: ハードウェア リソースのボトルネックが原因で、仮想マシンのAvamarゲスト バックアップが低速で実行されます。

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

ゲスト オペレーティング システムにAvamarクライアントがインストールされている仮想マシンで、不安定または低パフォーマンスが発生します。

バックアップが完了せずにバックアップ ウィンドウの最後に達すると、Avamarはバックアップが「time out - end」で失敗すると報告します。


例:-
次に、仮想化されたクライアントのログを確認し、不安定な動作を経験しました。  

次に、同じクライアントの高速バックアップと低速バックアップを示します。

高速バックアップのログには、1時間あたり2,291,881ファイルのピーク パフォーマンス 率が表示されます。このバックアップのファイルとデータの変更率は低くなっています。
2015-09-14 00:49:20 avtar Info <5156>: Backup #12 timestamp 
2015-09-14 00:49:20, 13,050,798 files, 1,352,497 folders, 9,671 GB (37,919 files, 437.1 MB, 0.00% new)
2015-09-14 00:49:20 avtar Info <6083>: Backed-up 9,671 GB in 341.66 minutes: 1,698 GB/hour (2,291,881 files/hour)

ログ ステータス メッセージは、バックアップの過程で、ファイルスキャンレートが一定であり、高速または低速の期間がないことを示します。  
CPUの利用率も40~60%
の間で適度に一定です。次に、Avamarクライアントのログを解析し、データをチャート化する内部Dellツールを使用して、この図を示します。

処理されたファイルを示すAvamarクライアント ログを解析する内部Dellツール時間の経過とともにCPU統計を表示するAvamarクライアント ログを解析する内部Dellツール これらのグラフは、良好な条件下でバックアップが迅速に実行されることを示しています。
ストレージ システムは、CPUを中程度の使用率レベルに保つ速度でファイルをavtarに供給しています。

次に、低速なバックアップのログを確認します。このバックアップは、同じクライアント データに対して行われますが、仮想ハードウェアのロード状況は異なります。ファイル/時のパフォーマンスは <400,000ファイル/時です。  
変更率が低いため、高速バックアップと同様に、バックアップの動作は同等です。

ログの下には、バックアップパフォーマンスが速く始まり、その後遅くなることがグラフィカルに表示されます(赤いボックス内でハイライト表示されている領域)。
2015-09-22 07:41:35 avtar Info <5157>: PARTIAL Backup #35 timestamp 
2015-09-22 07:41:35, 9,190,850 files, 1,030,683 folders, 8,283 GB (22,390 files, 397.8 MB, 0.00% new)
2015-09-22 07:41:35 avtar Info <6083>: Backed-up 8,283 GB in 1440.19 minutes: 345 GB/hour (382,902 files/hour)

時間の経過とともに処理されたファイルを示すAvamarクライアント ログを解析する内部Dellツール時間の経過とともにCPU使用率を示すAvamarクライアント ログを解析する内部Dellツール 1時間あたりの低速ファイルのパフォーマンスは、午前11時~午後7時の期間と正確に関連づけられます。

午前11時~午後7時のCPUの利用率が、40%を大きく上回る値から約5~10%に低下する点に注意してください。  

午後7時以降のCPUの利用率は15~20%から変動し、1時間あたりのファイルのパフォーマンスは向上しますが、バックアップの最初の部分ほど高くはありません。  
 

Causa

「サンプル クライアント」のデータセットは予測可能であり、変更率はごくわずかです。クライアントは毎日同様の作業を行い、

不安定なパフォーマンスは、ファイルのスキャン中にAvamarが使用する共有ハードウェア リソースの競合によるものです。  

上記の例では、ハードウェア リソースは需要が高いか、ピーク時にクライアントに対して調整されています。

動作は使用可能なリソースによって異なります。ボトルネックになる可能性が最も高いリソースは、データが配置されているストレージ デバイス上のランダム シークI/O要求です。

ピーク時にCPU使用率が急上昇した場合、ボトルネックは仮想マシンで使用可能なCPU共有の不足である可能性があります。

Risoluzione

  • クライアントが通常の業務に大きく依存していない場合は、オフピーク時および(可能な場合)バックアップを実行します。
  • バックアップ ウィンドウの時点で、仮想マシンのハイパーバイザーがCPU、メモリー、またはI/Oの制限を適用しないことを確認します。
  • 共有ストレージの競合が多い場合は、アクティビティの多い期間でAvamarバックアップが重複しないようにします。
  • 変更率の低いアプリケーションの場合は、イメージ ベースのバックアップの使用を検討してください。イメージ バックアップ プロキシ アプライアンスは、変更されたブロックのみをバックアップします。データセット内のすべてのファイルをスキャンするわけではないため、I/O要件が低くなります。

Informazioni aggiuntive

Avamarバックアップ パフォーマンスの問題を調査する方法の詳細については、 を参照してください。
avtarステータス メッセージの分析と解釈の詳細については、次を参照してください。

Prodotti interessati

Avamar

Prodotti

Avamar
Proprietà dell'articolo
Numero articolo: 000164580
Tipo di articolo: Solution
Ultima modifica: 10 feb 2025
Versione:  4
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.