VPLEX: While creating Extent from VPLEX getting WARNING: Could not determine thin-capability for storage-volume
Riepilogo: This article talks to when creating an extent a warning that appears about not being able to determine if the storage-volume the extent is made on top of is thin capable.
Questo articolo si applica a
Questo articolo non si applica a
Questo articolo non è legato a un prodotto specifico.
Non tutte le versioni del prodotto sono identificate in questo articolo.
Sintomi
New Storage-Volumes have been presented to the VPLEX yet the 'array re-discover' command was not run after the storage was provisioned to the VPLEX.
While creating an extent from a storage-volume on the VPLEX provisioned from an backend array you the following warning:
VPlexcli:/clusters/cluster-1> extent create -d xxxxx_7475_xxxxx01_02_data_xx
WARNING: Could not determine thin-capability for storage-volume: xxxxxx_7475_xxxxx01_02_data_xx. Any new extents supported by this storage-volume could potentially lose thin-capability.
While creating an extent from a storage-volume on the VPLEX provisioned from an backend array you the following warning:
VPlexcli:/clusters/cluster-1> extent create -d xxxxx_7475_xxxxx01_02_data_xx
WARNING: Could not determine thin-capability for storage-volume: xxxxxx_7475_xxxxx01_02_data_xx. Any new extents supported by this storage-volume could potentially lose thin-capability.
Causa
This warning appears when the 'array re-discover' command has not been performed after presenting a Storage-Volume/LUN to the VPLEX.
Risoluzione
Before performing the 'array re-discover' check the status and storage-volume to confirm if everything looks good.
To avoid this warning always perform an 'array re-discover' immediately after provisioning a new LUN(s) to VPLEX.
1. Run the following command after provisioning storage to VPLEX:
VPlexcli:/> array re-discover --array <Array Name>-<array serial number> --cluster cluster-x
If you do not know the array name and serial number you can check those array's attached to the VPLEX by using the command 'll /clusters/*/storage-element/storage-arrays'
Sample output:
2. After performing the 'array re-discover', try to create an extent again to confirm the issue is resolved.
3. In case issue is still persist you will need to confirm if the backend array is configured with VPLEX correctly. Refer to the best practices guide to properly connect a backend array to VPLEX.
Refer to the VPLEX SAN Connectivity Best Practices Guide: VPLEX SAN Connectivity Best Practices Guide
4. If everything looks correct, the end user may need open a Live Chat with Dell EMC Customer Service for further assistance and reference this article.
To avoid this warning always perform an 'array re-discover' immediately after provisioning a new LUN(s) to VPLEX.
1. Run the following command after provisioning storage to VPLEX:
VPlexcli:/> array re-discover --array <Array Name>-<array serial number> --cluster cluster-x
If you do not know the array name and serial number you can check those array's attached to the VPLEX by using the command 'll /clusters/*/storage-element/storage-arrays'
Sample output:
VPlexcli:/> ll /clusters/*/storage-elements/storage-arrays/
/clusters/cluster-1/storage-elements/storage-arrays:
Name Connectivity Auto Ports Logical
--------------------------- Status Switch ------------------- Unit
--------------------------- ------------ ------ ------------------- Count
--------------------------- ------------ ------ ------------------- -------
EMC-CLARiiON-APM00xxxxxxxx ok true 0x500xxxxxxxx0084b, 9
0x500xxxxxxxx0084b,
0x500xxxxxxxx0084b,
0x500xxxxxxxx0084b
/clusters/cluster-2/storage-elements/storage-arrays:
Name Connectivity Auto Ports Logical
--------------------------- Status Switch ------------------- Unit
--------------------------- ------------ ------ ------------------- Count
--------------------------- ------------ ------ ------------------- -------
EMC-CLARiiON-APM00xxxxxxxxx ok true 0x500xxxxxxxx0084b, 6
0x500xxxxxxxx0084b,
0x500xxxxxxxx0084b,
0x500xxxxxxxx0084b
/clusters/cluster-1/storage-elements/storage-arrays:
Name Connectivity Auto Ports Logical
--------------------------- Status Switch ------------------- Unit
--------------------------- ------------ ------ ------------------- Count
--------------------------- ------------ ------ ------------------- -------
EMC-CLARiiON-APM00xxxxxxxx ok true 0x500xxxxxxxx0084b, 9
0x500xxxxxxxx0084b,
0x500xxxxxxxx0084b,
0x500xxxxxxxx0084b
/clusters/cluster-2/storage-elements/storage-arrays:
Name Connectivity Auto Ports Logical
--------------------------- Status Switch ------------------- Unit
--------------------------- ------------ ------ ------------------- Count
--------------------------- ------------ ------ ------------------- -------
EMC-CLARiiON-APM00xxxxxxxxx ok true 0x500xxxxxxxx0084b, 6
0x500xxxxxxxx0084b,
0x500xxxxxxxx0084b,
0x500xxxxxxxx0084b
2. After performing the 'array re-discover', try to create an extent again to confirm the issue is resolved.
3. In case issue is still persist you will need to confirm if the backend array is configured with VPLEX correctly. Refer to the best practices guide to properly connect a backend array to VPLEX.
Refer to the VPLEX SAN Connectivity Best Practices Guide: VPLEX SAN Connectivity Best Practices Guide
4. If everything looks correct, the end user may need open a Live Chat with Dell EMC Customer Service for further assistance and reference this article.
Informazioni aggiuntive
This content is translated in different languages:
| https://downloads.dell.com/TranslatedPDF/AR-SA_535802.pdf |
| https://downloads.dell.com/TranslatedPDF/DE_535802.pdf |
| https://downloads.dell.com/TranslatedPDF/ES_535802.pdf |
| https://downloads.dell.com/TranslatedPDF/ES-XL_535802.pdf |
| https://downloads.dell.com/TranslatedPDF/FR_535802.pdf |
| https://downloads.dell.com/TranslatedPDF/IT_535802.pdf |
| https://downloads.dell.com/TranslatedPDF/JA_535802.pdf |
| https://downloads.dell.com/TranslatedPDF/KO_535802.pdf |
| https://downloads.dell.com/TranslatedPDF/NL_535802.pdf |
| https://downloads.dell.com/TranslatedPDF/PT_535802.pdf |
| https://downloads.dell.com/TranslatedPDF/PT-BR_535802.pdf |
| https://downloads.dell.com/TranslatedPDF/RU_535802.pdf |
| https://downloads.dell.com/TranslatedPDF/SV_535802.pdf |
| https://downloads.dell.com/TranslatedPDF/ZH-CN_535802.pdf |
| https://downloads.dell.com/TranslatedPDF/ZH-TW_535802.pdf |
Prodotti interessati
VPLEX SeriesProdotti
VPLEX for All Flash, VPLEX GeoSynchrony, VPLEX Series, VPLEX VS2, VPLEX VS6Proprietà dell'articolo
Numero articolo: 000168350
Tipo di articolo: Solution
Ultima modifica: 07 ott 2025
Versione: 4
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.