Isilon:修补程序状态显示为 AdHoc

Riepilogo: “isi upgrade patches list”命令的输出显示修补程序处于 AdHoc 状态,而不是预期的 Installed 状态。

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi



mycluster-3# isi upgrade patches list

修补程序名称说明 Status
--------------------------------------------------------------------------
patch-248568 [8.1.2.0 UGA-RUP 2019-04] 多个用户空间修复...AdHoc
修补程序-248570 [8.1.2.0 KGA-RUP 2019-04] 多个内核/重新启动 R...
临时--------------------------------------------------------------------------

修补程序的状态应显示为“已安装”。

Causa

发生升级回滚,但未能完成。

临时状态意味着修补程序已安装在部分(甚至所有)节点上,但未注册到群集。当使用 isi_patch 实用程序安装修补程序但从未使用“isi upgrade patches”命令安装修补程序时,通常会发生这种情况。

Risoluzione

使用“isi upgrade patches view <patch>”命令将显示安装修补程序的节点 ID 列表。示例缩写输出如下所示:

mycluster-3# isi upgrade patches view patch-248568
Patch name: patch-248568
Description:[8.1.2.0 UGA-RUP 2019-04]多个用户空间修复(2019 年 4 月)
状态:
临时节点:      2、3、4、5、6

要使修补程序进入正常的“已安装”状态,只需使用正常的“isi upgrade patches install”命令再次安装修补程序即可。对于实际已安装补丁的节点,这将注册补丁;对于缺少修补程序的节点,这将安装修补程序。

如果修补程序实际上列为已在所有节点上安装,则执行“isi upgrade patches install”命令只会清理群集修补程序注册。由于如果“isi upgrade patches view”显示节点上的修补程序,则会跳过节点,因此不会发生中断或实际的修补程序安装活动。如果使用“view”命令列出为已在所有节点上安装修补程序,则在执行安装命令时将清理和更正群集修补程序注册表。

但是,对于未安装修补程序的任何节点,执行命令将安装修补程序,其后果是安装修补程序(服务重新启动或节点重新启动)。如果有疑问,请在离线窗口中执行命令。

执行命令后(如上例所示),会看到以下内容:
mycluster-3# isi upgrade patches install patch-248568

mycluster-3# isi upgrade patches list

Patch Name Description Status
----------------------------------------------------------------------------
patch-248568 [8.1.2.0 UGA-RUP 2019-04] Multiple Userspace Fixes...安装了
patch-248570 [8.1.2.0 KGA-RUP 2019-04] 多个内核/重新启动 r...
临时----------------------------------------------------------------------------
总计:2

Prodotti interessati

Isilon

Prodotti

Isilon, PowerScale OneFS
Proprietà dell'articolo
Numero articolo: 000168738
Tipo di articolo: Solution
Ultima modifica: 04 apr 2025
Versione:  3
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.