IDPA vCenter-upgrade mislukt met fout "vCSACliInstallLogger - ERROR - vCenter Server Data Export failed"
Riepilogo: Dit KB-artikel leidt u door een vCenter-upgradefout die wordt veroorzaakt doordat het exporteren van vCenter DB mislukt. Dit kan het gevolg zijn van een beschadiging van de vCenter DB.
Questo articolo si applica a
Questo articolo non si applica a
Questo articolo non è legato a un prodotto specifico.
Non tutte le versioni del prodotto sono identificate in questo articolo.
Sintomi
Op de ACM kan het vCenter worden weergegeven als mislukt.
Ga naar het vCenter Upgrade logboek onder de map '/data01/tmp/patch/logs/VCSA', waar de volgende fouten worden weergegeven op vcsaclientinstaller log:
Progress: 42% Exporting VMware vCenter Server Database data...
2020-03-26 03:41:00,145 - vCSACliInstallLogger - ERROR - vCenter Server Data Export failed.
2020-03-26 03:41:00,145 - vCSACliInstallLogger - ERROR - Upgrade failed:
Status: ERROR
Progress: 42% Exporting VMware vCenter Server Database data...
Error:
Problem Id: None
Component key: upgrade_framework
Detail:
Error while exporting source SET tables: pg_dump: Error message from server: ERROR: invalid page in block 9 of relation base/16384/25164
Oplossing: Lees de logboekbestanden en los de problemen op die zijn gevonden in uw SET-brontabellen.
2020-03-26 03:41:00,145 - vCSACliInstallLogger - INFO - Zie het bestand /data01/tmp/patch/logs/vclogs/monitor-firstboot-progress-oczvL_.json op de lokale computer of het bestand /var/log/vmware/upgrade/export.json op de externe computer voor meer informatie.
Daarnaast kunnen op de vCenter-server de upgradelogboeken onder '/var/log/vmware/upgrade' ook worden geverifieerd en ze kunnen de volgende foutberichten weergeven:
VMware License Service data...
2020-03-26 17:09:01,732 - vCSACliInstallLogger - INFO - vCenter Server Data Export: Progress: 42% Exporting VMware vCenter Server Database data...
2020-03-26 17:09:12,296 - vCSACliInstallLogger - ERROR - vCenter Server Data Export failed.
2020-03-26 17:09:12,296 - vCSACliInstallLogger - ERROR - Upgrade failed:
Status: ERROR
Progress: 42% Exporting VMware vCenter Server Database data...
Error:
Problem Id: None
Component key: upgrade_framework
Detail:
Error while exporting source SET tables: pg_dump: Error message from server: ERROR: invalid page in block 9 of relation base/16384/25164
Oplossing: Lees de logboekbestanden en los de problemen op die zijn gevonden in de SET-brontallen.
2020-03-26 17:09:12,296 - vCSACliInstallLogger - INFO - Zie het bestand /data01/tmp/patch/logs/vclogs/monitor-firstboot-progress-tmcn2I.json op de lokale computer of het bestand /var/log/vmware/upgrade/export.json op de externe computer voor meer informatie.
2020-03-26 17:09:12,305 - vCSACliInstallLogger - INFO - De logboekbundel van Vc-support wordt verzameld. Dit kan een paar minuten duren.
2020-03-26 17:09:12,583 - vCSACliInstallLogger - INFO - Verwijdering VMware-upgradevereisten-* op 192.168.100.99.
2020-03-26 17:09:13,881 - vCSACliInstallLogger - ERROR - (u'Failed to uninstall %(rpm)s on %(host)s: %(error)s', {'host': u'192.168.100.99', 'rpm': u'vmware-upgrade-requirements-*', 'error': CommandError(u"Failed to run and wait for command in guest with error 'Command '/bin/rpm' exited with non-zero status 1'",)}))
postgres.log op de vCenter toont het volgende foutbericht:
816 UTC 5e7ce0cc.7647 24294965 LOG: automatic analyze of table "VCDB.vc.vpx_event_arg" system usage: CPU 0.02s/1.53u sec elapsed 6.15 sec
2020-03-26 17:08:19.502 UTC 5e7ce180.2530 24295002 LOG: automatic analyze of table "VCDB.vc.vpx_event" system usage: CPU 0.00s/2.40u sec elapsed 2.79 sec
2020-03-26 17:08:58.326 UTC 5e7c377f.3892 0 VCDB vc LOG: unexpected EOF on client connection with an open transaction
2020-03-26 17:08:58.326 UTC 5e7c3796.3a7b 0 VCDB vc LOG: unexpected EOF on client connection with an open transaction
2020-03-26 17:08:58.327 UTC 5e7c3796.3a81 0 VCDB vc LOG: unexpected EOF on client connection with an open transaction
2020-03-26 17:09:09.530 UTC 5e7ce1b3.3c67 0 VCDB postgres ERROR: invalid page in block 9 of relation base/16384/25164
2020-03-26 17:09:09.530 UTC 5e7ce1b3.3c67 0 VCDB postgres STATEMENT: COPY vc.vpx_topn_past_month (counter_id, sample_time, integral_value) TO stdout;
SET zero_damaged_pages = on; select * from <corrupted table>; SET zero_damaged_pages = off;
VCDB=# select counter_id from vpx_topn_past_month;
ERROR: invalid page in block 9 of relation base/16384/25164
Causa
Door corruptie van de vCenter Postgres-database is vCenter Upgrade mislukt tijdens de DB-exporttaak.
Risoluzione
Stap 1: Meld u aan bij de IDPA vCenter UI.
Stap 2: Maak een kloon van vCenter VM.
Stap 3: Voer een rollback uit voor de vCenter VM op de ACM UI.
Stap 4: SSH naar vCenter VM en stop de vpxd-service.
Stap 5: Meld u aan bij vCenter Postgres DB.
Stap 2: Maak een kloon van vCenter VM.
- Klik met de rechtermuisknop op VCSA VM --> Clone to Virtual Machine.
- Kies de naam van de kloon en andere gegevens en klik op OK.
Stap 3: Voer een rollback uit voor de vCenter VM op de ACM UI.
- Klik op het selectievakje Troubleshooting Options. Klik op Rollback for vCenter Upgrade.
Stap 4: SSH naar vCenter VM en stop de vpxd-service.
- service-control --stop vpxd
Stap 5: Meld u aan bij vCenter Postgres DB.
- /opt/vmware/vpostgres/current/bin/psql -d VCDB -U postgres
- SET zero_damaged_pages = on;
- VACUUM FULL ANALYSE VERBOSE;
- REINDEX table vpx_topn_past_month;
- select * from vpx_topn_past_month;
- SET zero_damaged_pages = off;
Informazioni aggiuntive
Betrek VMware support als het probleem niet is opgelost nadat u de bovenstaande stappen hebt uitgevoerd.
Prodotti interessati
Integrated Data Protection Appliance FamilyProdotti
PowerProtect DP4400, PowerProtect DP5300, PowerProtect DP5800, PowerProtect DP8300, PowerProtect DP8800, PowerProtect Data Protection Software, Integrated Data Protection Appliance Family, PowerProtect Data Protection Hardware
, Integrated Data Protection Appliance Software
...
Proprietà dell'articolo
Numero articolo: 000173289
Tipo di articolo: Solution
Ultima modifica: 27 mag 2025
Versione: 3
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.