PowerStore: Server NAS non raggiungibile a causa della non disponibilità di NTP

Riepilogo: Server NAS non raggiungibile, a causa del server NTP non disponibile dal sistema PowerStore

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Sintomi

Impossibile raggiungere un server NAS dal client, viene visualizzato il messaggio di errore "Windows cannot access \\X.X.X.X." Quando si tenta di accedere utilizzando "dir \\X.X.X.X" in cmd, il messaggio di errore è "Could not find the domain controller for this domain".
Nei registri del journal vengono visualizzati errori relativi alla sincronizzazione dell'ora, ad esempio:

WARNING: kerberos function 'krb5_sendto_kdc' fails. Returning time error: Clock skew too great

È inoltre possibile verificare che la connettività al controller di dominio non riesca dalla CLI di PowerStore:

[SVC:service@SVCTAGX-B user]$ svc_nas_cifssupport --server nas-server-x --args "-checkup "
nas-server-x
Error: unable getting a reply from '[xxxxxxxxxxxxxxxx]:5082'.
Error: timeout

nas-server-x :
------------------------------------Checks--------------------------------------

Component CIFS :

ACL       : Checking the number of ACLs per file system. ..................*Pass
Connection: Checking the load of CIFS TCP connections. .................... Pass
Credential: Checking the validity of credentials. ......................... Pass
DC        : Checking the connectivity and configuration of Domain Controlle*FAILURE
DFS       : Checking the DFS configuration files and DFS registry. ........ Pass
DNS       : Checking the DNS configuration and connectivity to DNS servers. Pass
EventLog  : Checking the configuration of Windows Event Logs. ............. FAILURE
FS_Type   : Checking the dirType of each file system (DIR3 format for UFS32 Pass
GPO       : Checking the GPO configuration. ............................... FAILURE
HomeDir   : Checking the configuration of home directory shares. .......... Pass
I18N      : Checking the I18N mode and the Unicode/UTF8 translation tables. Pass
Kerberos  : Checking password updates and AES for Kerberos. ...............

 

Causa

Il server NTP non può essere raggiunto dal sistema. L'autenticazione Kerberos ha esito negativo a causa dello sfasamento temporale.
Lo stesso server NTP potrebbe aver funzionato in precedenza, ma se inaffidabile potrebbe essere ora diventato irraggiungibile.

Confermarlo con il comando "svc_ntp_ctl" (si può anche provare a risincronizzare contemporaneamente aggiungendo il flag --set)

[SVC:service@SVCTAGX-B user]$ svc_ntp_ctl --set
   INFO: Cluster is configured to use the following NTP servers: xx.xx.xx.xx
  ERROR: Node B could not reach any valid time server.
   INFO: Time sync service restarted successfully
  ERROR: Node A could not reach any valid time server.
   INFO: Time sync service restarted successfully

 

Risoluzione

Verificare la disponibilità e la raggiungibilità del server NTP, se necessario passare a un altro server NTP attivo e raggiungibile (da Impostazioni di PowerStore Manager >> Networking > Infrastructure Services).
Quindi forzare nuovamente una sincronizzazione, questa volta dovrebbe avere esito positivo, dopodiché è possibile raggiungere nuovamente il server NAS.

[SVC:service@SVCTAGX-B user]$ svc_ntp_ctl --set
   INFO: Cluster is configured to use the following NTP servers: xx.xx.xx.x1, xx.xx.xx.x2
   INFO: Node B synced with server xx.xx.xx.x1 and has an offset of 0.000982 seconds
   INFO: Time sync service restarted successfully
   INFO: Node A synced with server xx.xx.xx.x2 and has an offset of 0.001301 seconds
   INFO: Time sync service restarted successfully

 

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Prodotti

PowerStore 9000X
Proprietà dell'articolo
Numero articolo: 000182993
Tipo di articolo: Solution
Ultima modifica: 20 gen 2025
Versione:  2
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