Dell Unity: No se puede renovar ni eliminar el certificado VASA debido a que la cadena de certificados es demasiado larga (corregible por el usuario)

Riepilogo: Hay muchas razones para ser incapaz de renovar o eliminar un certificado VASA. En este artículo, se aborda solo el intento de renovar o eliminar cuando falla la validación del certificado debido al error "Certificate Chain too long". ...

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Cuando se intenta renovar el certificado VASA desde vSphere, se produce un error:     
 
"The provider certificate is invalid. It is either empty, malformed, or expired, not yet valid, revoked, or fails host name verification."

1

2
 

El problema no se puede resolver con el artículo de la base de conocimientos:     
Cuando intente quitar un certificado de Unity mediante UEMCLI:    
  • El resultado es el correcto, pero el certificado permanece en el sistema.
  • El resultado es el error: "The certificate does not exist. (Código de error: 0x6000940)"
Ejemplo de ambos puntos:
service@spb~# uemcli -no -u admin -p /sys/cert -id vasa_http-vc1-servercert-1 delete Operation completed successfully. service@spb~# uemcli -no -u admin -p /sys/cert show 1: ID = vasa_http-vc1-cacert-1 Type = CA Service = VASA_HTTP Certificate ID = vasa_http-vc1-cacert-1 service@spb~# uemcli -no -u admin -p /sys/cert -id vasa_http-vc1-servercert-1 delete Operation failed. Código de error: 0x6000940 El certificado no existe. (Error Code:0x6000940) service@spb~# uemcli -no -u admin -p /sys/cert show 1: ID = vasa_http-vc1-cacert-1 Type = CA Service = VASA_HTTP Certificate ID = vasa_http-vc1-cacert-1

Causa

En este problema en particular, se descubrió que la cadena de certificados era demasiado larga. El alcance máximo de verificación SSL estipulado en Unity OE 5.0.6 y versiones anteriores es 1, y este certificado en particular tenía un alcance de 3.

Risoluzione

Este problema se abordará en una próxima versión de Unity OE.

Para conocer más detalles sobre las versiones de Unity OE, consulte el artículo de la base de conocimientos 20641: Matriz de revisión de Dell EMC Unity OE (corregible por el usuario)

Existe una solución alternativa que consiste en los siguientes puntos:   
  1. El soporte técnico cambiará el valor del alcance de verificación de SSL.
  2. El soporte técnico eliminará todos los certificados que aparecen en el arreglo
  3. El soporte técnico reiniciará los servicios de administración (esto no interrumpirá la producción)
  4. El administrador de Unity agregará Unity como proveedor de almacenamiento VASA en vSphere.
Para implementar esta solución alternativa en el arreglo Unity, comuníquese con el soporte y mencione el número de artículo 185269.

Prodotti interessati

Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity 500, Dell EMC Unity 500F, Dell EMC Unity 550F, Dell EMC Unity 600

Prodotti

Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity 600F, Dell EMC Unity 650F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F , Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid ...
Proprietà dell'articolo
Numero articolo: 000185269
Tipo di articolo: Solution
Ultima modifica: 20 ott 2025
Versione:  5
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.