Dell Unity: Nie można odnowić/usunąć certyfikatu VASA ze względu na zbyt długi łańcuch certyfikatów (możliwość korekty z poziomu użytkownika)

Riepilogo: Jest wiele powodów, dla których nie można odnowić/usunąć certyfikatu VASA. W tym artykule opisano tylko próbę odnowienia/usunięcia w przypadku niepowodzenia weryfikacji certyfikatu ze względu na „Zbyt długi łańcuch certyfikatów”. ...

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Podczas próby odnowienia certyfikatu VASA z vSphere występuje błąd:     
 
„Certyfikat dostawcy jest nieprawidłowy. Jest pusty, zdeformowany lub wygasł, nie jest jeszcze prawidłowy, odwołany lub nie można zweryfikować nazwy hosta”.

1

2
 

Nie można rozwiązać problemu przy użyciu bazy wiedzy:     
Podczas próby usunięcia certyfikatu z Unity za pomocą UEMCLI:    
  • Wynik jest pomyślny, ale certyfikat pozostaje w systemie.
  • Wynik jest niepomyślny i występuje błąd: „The certificate does not exist. (Error Code:0x6000940)”
Przykład obu punktów:
service@spb~# uemcli -no -u admin -p /sys/cert -id vasa_http-vc1-servercert-1 delete Operation completed successfully. service@spb~# uemcli -no -u admin -p /sys/cert show 1: ID = vasa_http-vc1-cacert-1 Type = CA Service = VASA_HTTP Certificate ID = vasa_http-vc1-cacert-1 service@spb~# uemcli -no -u admin -p /sys/cert -id vasa_http-vc1-servercert-1 delete Operation failed. Kod błędu: 0x6000940 The certificate does not exist. (Error Code:0x6000940) service@spb~# uemcli -no -u admin -p /sys/cert show 1: ID = vasa_http-vc1-cacert-1 Type = CA Service = VASA_HTTP Certificate ID = vasa_http-vc1-cacert-1

Causa

W przypadku tego konkretnego problemu stwierdzono, że łańcuch certyfikatów był zbyt długi. Maksymalna dopuszczalna głębokość weryfikacji SSL w Unity OE 5.0.6 i wcześniejszych wersjach to 1, a ten konkretny certyfikat miał głębokość 3.

Risoluzione

Ten problem zostanie rozwiązany w nadchodzącej wersji Unity OE.

Więcej informacji na temat wersji Unity OE można znaleźć w artykule bazy wiedzy 20641: Tabela wersji Dell EMC Unity OE (z możliwością korekty z poziomu użytkownika)  

Istnieje obejście problemu, które obejmuje następujące działania:   
  1. Dział pomocy technicznej zmienia wartość głębokości weryfikacji SSL.
  2. Dział pomocy technicznej usuwa wszystkie certyfikaty wymienione w macierzy
  3. Dział pomocy technicznej ponownie uruchamia usługi zarządzania (nie spowoduje to zakłócenia produkcji)
  4. Administrator Unity dodaje Unity jako dostawcę pamięci masowej VASA w vSphere.
Aby wdrożyć to obejście problemu w macierzy Unity, skontaktuj się z działem pomocy technicznej i podaj numer artykułu 185269.

Prodotti interessati

Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity 500, Dell EMC Unity 500F, Dell EMC Unity 550F, Dell EMC Unity 600

Prodotti

Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity 600F, Dell EMC Unity 650F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F , Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid ...
Proprietà dell'articolo
Numero articolo: 000185269
Tipo di articolo: Solution
Ultima modifica: 20 ott 2025
Versione:  5
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.