AppSync: AppSync sendet keinen REST API-Befehl, um die logische Einheit zu bereinigen, was zu Fehlern in VPLEX führt.

Riepilogo: Während des Aushängevorgangs sollte AppSync einen REST API-Befehl senden, um die logische Einheit in VPLEX zu bereinigen. Das tut es jedoch nicht, sodass logische Einheiten in VPLEX nicht erreichbar sind und Fehler in der VPLEX-GUI angezeigt werden. ...

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Dem Kunden werden die folgenden Fehler in der VPLEX-GUI angezeigt:

ForgetUnReachableLun.jpg

Im selben Zeitrahmen wird der AppSync-Serviceplan angezeigt und die Aushängephase ist erfolgreich. 
Im Serverprotokoll wird nicht aufgeführt, dass AppSync die folgende API sendet, um die logische Einheit in VPLEX zu bereinigen.

<Date & Time> executeRequest: executing POST: POST https://<VPLX Server IP/Name>/vplex/logical-unit+forget HTTP/1.1
<Date & Time> executeRequest: Antwortstatuszeile: HTTP/1.1 200 OK
    
AppSync behauptet jedoch, dass der Vorgang, alle logischen Einheiten von VPLEX zu bereinigen, abgeschlossen wurde.

<Date & Time> INFO [EJB default - 5] [com.emc.archway.service.eventservice.EventServiceBean] [AppSync Server Name] [] 5e534c36-54c1-4874-921a-5a9fbb98eeed->>> EVENT [VPLEX_000052]: Vorgang auf dem VPLEX-Cluster <VPLEX ID> zum Bereinigen aller logischen Einheiten, die ausgehängt wurden, abgeschlossen. (METADATEN: TYPE-INFO, TIME-2021-06-03 04:06:42.450+0200NATIVETIME-<Date & Time> .450+0200, HOST-EMCAppSync, PHASE-Create 1st gen copy, THREAD=EJB default - 5, USER-null, CATEGORY-GENERIC, SESSIONID-null)

 

Causa

In AppSync 4.2 sendet AppSync aufgrund eines Codefehlers nicht den Befehl zum Bereinigen aller logischen Einheiten an die REST API, wenn nicht die entsprechenden Storage-Volume-Details aus dem Aufruf „get-storage-volume-info“ abgerufen werden, von dem die Anfrage „forget logical unit“ abhängt.  
 

Risoluzione

Für dieses Problem ist ein Hotfix vorhanden. Rufen Sie den Support an und verweisen Sie auf diesen KB-Artikel, um den Hotfix zu erhalten.

Prodotti

AppSync
Proprietà dell'articolo
Numero articolo: 000189275
Tipo di articolo: Solution
Ultima modifica: 03 nov 2021
Versione:  3
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.