PowerEdge: Errore "Relazione di trust tra workstation e dominio primario non riuscita" su Windows Server o computer client

Riepilogo: In un computer Windows aggiunto a un dominio Active Directory (AD) viene visualizzato l'errore "La relazione di trust tra questa workstation e il dominio primario non è riuscita". Ciò si verifica quando un utente tenta di accedere al dominio. Questo problema può spesso essere risolto rimuovendo il computer dal dominio e riaggigendolo. ...

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Sintomi

Un computer Windows membro di un dominio AD visualizza l'errore riportato di seguito quando un utente tenta di accedere al dominio. L'utente visualizza quindi nuovamente la richiesta di accesso, pertanto non è possibile effettuare l'accesso al dominio.
The trust relationship between this workstation and the primary domain failed.

Causa

Questo errore si verifica quando il canale sicuro tra il computer interessato e AD è interrotto. Il canale sicuro è il meccanismo mediante il quale i computer aggiunti a un dominio comunicano in modo sicuro con i controller di dominio e si basa sulla password associata a un account computer.

Ogni computer aggiunto a un dominio dispone di un account in Active Directory e a ogni account computer è associata una password. Queste password dell'account del computer sono separate dalle password degli account utente e vengono gestite, sincronizzate e aggiornate automaticamente senza necessità di interazione dell'utente. In alcune situazioni, tuttavia, la copia del computer della relativa password non viene sincronizzata con la copia archiviata in AD. In questo caso, il canale sicuro non può essere stabilito e l'errore di cui sopra viene visualizzato quando un utente tenta di accedere al dominio.

Risoluzione

Questo problema viene spesso risolto rimuovendo il computer interessato dal dominio aggiungendolo a un gruppo di lavoro e quindi riaggiungendolo al dominio. Procedere nel modo seguente:

 
Nota: i seguenti passaggi presuppongono che il computer interessato possa essere rimosso dal dominio senza conseguenze negative. A seconda del ruolo funzionale della macchina e del software installato su di essa, questo potrebbe non essere vero. Inoltre, questi passaggi richiedono l'accesso a un account amministrativo locale sul computer interessato. Se non è possibile accedere a un account amministrativo locale, il ripristino del sistema da un backup potrebbe essere l'unica opzione.
 
  1. Accedere a un account amministrativo locale sul computer interessato.
  2. Aprire la finestra Proprietà del sistema. A seconda della versione di Windows in esecuzione sul computer, ci sono diversi modi per eseguire questa operazione.
    • In Windows Server, avviare Server Manager, cliccare su Server locale nel riquadro sinistro e sul nome del dominio nel riquadro principale.
    • In un client Windows, cliccare sull'icona Start e iniziare a digitare advanced system settings. Selezionare Visualizza impostazioni di sistema avanzate quando viene visualizzata l'opzione.
  3. Nella scheda Nome computer cliccare sul pulsante Cambia.
  4. Selezionare Workgroup e digitare il nome di un gruppo di lavoro. Il nome specifico non è importante, in quanto si tratta di un gruppo di lavoro temporaneo. Cliccare su OK.
  5. Cliccare su OK per accettare le finestre di dialogo visualizzate.
  6. Cliccare su Chiudi per chiudere la finestra Proprietà del sistema. Riavviare il computer quando possibile.
  7. Al prompt di accesso, accedere allo stesso account amministrativo locale precedente.
  8. Aprire la finestra Proprietà del sistema.
  9. Nella scheda Nome computer cliccare sul pulsante Cambia.
  10. Selezionare Domain e digitare il nome del dominio AD. Cliccare su OK.
  11. Fornire le credenziali di un account utente di dominio con autorizzazione di aggiunta del computer al dominio. Cliccare su OK.
  12. Cliccare su OK per accettare le finestre di dialogo visualizzate.
  13. Cliccare su Chiudi per chiudere la finestra Proprietà del sistema. Riavviare il computer quando possibile.
  14. Al prompt di accesso, verificare che sia possibile accedere a un account di dominio senza ricevere un errore.
Se il problema persiste dopo aver completato i passaggi precedenti, potrebbe essersi verificato un problema con la replica di Active Directory nel dominio. I problemi di replica possono essere complessi e non rientrano nell'ambito di questo articolo.

Prodotti interessati

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Modular Infrastructure, Rack Servers, Tower Servers
Proprietà dell'articolo
Numero articolo: 000201765
Tipo di articolo: Solution
Ultima modifica: 05 set 2025
Versione:  13
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