NetWorker : La connexion NMC échoue avec le message « There is a problem contacting the server, server_hostname. Vérifiez que le serveur est en cours d’exécution. »
Riepilogo: Lorsque vous tentez de vous connecter au serveur NetWorker Management Console (NMC), un message d’erreur s’affiche : « Il y a un problème pour contacter le serveur, server_hostname. Vérifiez que le serveur est en cours d’exécution. » Apparaît ...
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Sintomi
- Après une tentative de connexion à NetWorker Management Console (NMC), le message d’erreur suivant s’affiche :
Il y a un problème pour contacter le serveur, server_hostname. Vérifiez que le serveur est en cours d’exécution. »
Causa
Le pare-feu du serveur NMC n’autorise pas la création de connexions vers les ports TCP 9000 et/ou 9001.
Le port 9000 est utilisé par le processus HTTP NMC lors de la connexion entre le client NMC et le serveur NMC.
Le port 9001 est utilisé pour les appels RPC de la console Java vers le serveur NMC.
Le port 9000 est utilisé par le processus HTTP NMC lors de la connexion entre le client NMC et le serveur NMC.
Le port 9001 est utilisé pour les appels RPC de la console Java vers le serveur NMC.
Risoluzione
1. Sur le serveur NMC, assurez-vous que le processus NMC est en cours d’exécution et que les ports 9000 et 9001 sont à l’écoute :
2, une. Vérifiez si le pare-feu du système d’exploitation est activé.
2, b. Si le pare-feu est activé, désactivez-le temporairement et confirmez que vous pouvez vous connecter aux ports 9000 et 9001 à partir du client NMC :
3. Si le pare-feu du système d’exploitation doit être activé, configurez les règles de pare-feu pour accepter les ports 9000 et 9001. Ces ports sont détaillés dans le Guide de configuration de la sécurité NetWorker, disponible ici : https://www.dell.com/support/home/product-support/product/networker/docs
Linux :
systemctl status gst
netstat -apno | grep « 9000\|9001 »
netstat -apno | grep « 9000\|9001 »
Windows. :
liste des tâches | findstr gst
netstat -aof | findstr 9000
netstat -aof | findstr 9001
netstat -aof | findstr 9000
netstat -aof | findstr 9001
2, une. Vérifiez si le pare-feu du système d’exploitation est activé.
Linux :
firewall-cmd --stat
Windows. :
netsh advfirewall show allprofiles state
OU
recherchez « Check firewall status »
OU
recherchez « Check firewall status »
Remarque : Si le pare-feu du système d’exploitation est déjà désactivé, contactez l’équipe réseau/sécurité pour voir s’il existe un pare-feu réseau entre le client NMC et les systèmes du serveur NMC.
2, b. Si le pare-feu est activé, désactivez-le temporairement et confirmez que vous pouvez vous connecter aux ports 9000 et 9001 à partir du client NMC :
Linux :
curl -v NMC_servername :port
Windows (PowerShell) :
Test-NetConnection -ComputerName NMC_servername -port PORT
Remarque : Si NetWorker est installé sur le système utilisé pour accéder à NMC, vous pouvez également utiliser la commande nsrports pour vérifier la résolution et la connectivité du port : nsrports -t NMC_servername -p port
Remarque : Reportez-vous à la documentation du fournisseur du système d’exploitation pour configurer les règles de pare-feu du système d’exploitation, car cela peut varier d’une distribution à l’autre. Si vous avez besoin d’aide pour configurer les règles de pare-feu, contactez l’administrateur système et le réseau local ou les équipes de sécurité.
Proprietà dell'articolo
Numero articolo: 000203361
Tipo di articolo: Solution
Ultima modifica: 15 set 2022
Versione: 1
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