NetWorker: Die NMC-Anmeldung schlägt fehl mit "Es gibt ein Problem bei der Kontaktaufnahme mit dem Server, server_hostname. Überprüfen Sie, ob der Server ausgeführt wird."
Riepilogo: Beim Versuch, sich beim NMC-Server (NetWorker Management Console) anzumelden, wird die Fehlermeldung "Es gibt ein Problem bei der Kontaktaufnahme mit dem Server server_hostname. Bitte überprüfen Sie, ob der Server ausgeführt wird." Erscheint ...
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Sintomi
- Nach dem Versuch, sich bei der NetWorker Management Console (NMC) anzumelden, wird die folgende Fehlermeldung angezeigt:
Es liegt ein Problem bei der Kontaktaufnahme mit dem Server vor, server_hostname. Bitte überprüfen Sie, ob der Server ausgeführt wird."
Causa
Die Firewall des NMC-Servers lässt keine eingehenden Verbindungen zu den TCP-Ports 9000 und/oder 9001 zu.
Port 9000 wird vom NMC-HTTP-Prozess verwendet, wenn eine Verbindung zwischen dem NMC-Client und dem NMC-Server hergestellt wird.
Port 9001 wird für RPC-Aufrufe von der Java-Konsole an den NMC-Server verwendet.
Port 9000 wird vom NMC-HTTP-Prozess verwendet, wenn eine Verbindung zwischen dem NMC-Client und dem NMC-Server hergestellt wird.
Port 9001 wird für RPC-Aufrufe von der Java-Konsole an den NMC-Server verwendet.
Risoluzione
1. Stellen Sie auf dem NMC-Server sicher, dass der NMC-Prozess ausgeführt wird und die Ports 9000 und 9001 empfangsbereit sind:
2, a. Überprüfen Sie, ob die Betriebssystem-Firewall aktiviert ist.
2, b. Wenn die Firewall aktiviert ist, deaktivieren Sie sie vorübergehend und bestätigen Sie, dass Sie vom NMC-Client aus eine Verbindung zu den Ports 9000 und 9001 herstellen können:
3. Wenn die Betriebssystemfirewall aktiviert werden muss, konfigurieren Sie die Firewallregeln so, dass die Ports 9000 und 9001 akzeptiert werden. Diese Ports sind im NetWorker-Sicherheitskonfigurationsleitfaden beschrieben, verfügbar unter: https://www.dell.com/support/home/product-support/product/networker/docs
Linux:
systemctl status gst
netstat -apno | grep "9000\|9001"
netstat -apno | grep "9000\|9001"
Windows:
Aufgabenliste | findstr gst
netstat -aof | findstr 9000
netstat -aof | findstr 9001
netstat -aof | findstr 9000
netstat -aof | findstr 9001
2, a. Überprüfen Sie, ob die Betriebssystem-Firewall aktiviert ist.
Linux:
firewall-cmd --stat
Windows:
netsh advfirewall show allprofiles state
ODER
suchen Sie nach "Check firewall status".
ODER
suchen Sie nach "Check firewall status".
HINWEIS: Wenn die Betriebssystemfirewall bereits deaktiviert ist, wenden Sie sich an das Netzwerk-/Sicherheitsteam, um festzustellen, ob eine Netzwerkfirewall zwischen dem NMC-Client und NMC-Serversystemen vorhanden ist.
2, b. Wenn die Firewall aktiviert ist, deaktivieren Sie sie vorübergehend und bestätigen Sie, dass Sie vom NMC-Client aus eine Verbindung zu den Ports 9000 und 9001 herstellen können:
Linux:
curl -v NMC_servername:Port
Windows (PowerShell):
Test-NetConnection -ComputerName NMC_servername -port PORT
HINWEIS: Wenn auf dem System, das für den Zugriff auf NMC verwendet wird, NetWorker installiert ist, können Sie auch den Befehl nsrports verwenden, um die Auflösung und Portkonnektivität zu überprüfen: nsrports -t NMC_servername -p port
HINWEIS: Informationen zum Konfigurieren der Firewallregeln des Betriebssystems finden Sie in der Dokumentation des Betriebssystemanbieters, da diese je nach Distribution variieren können. Wenn Unterstützung bei der Konfiguration von Firewallregeln erforderlich ist, ziehen Sie den Systemadministrator und lokale Netzwerk- oder Sicherheitsteams hinzu.
Proprietà dell'articolo
Numero articolo: 000203361
Tipo di articolo: Solution
Ultima modifica: 15 set 2022
Versione: 1
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