VxRail: Solo X di X unità vSAN in uso su questo nodo

Riepilogo: I dischi dell host non contribuiscono allo storage vSAN a causa di una configurazione errata effettuata sull'adattatore di storage PERC/HBA dei dischi vSAN.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

1 - Controller di storage mancante in "Host - Configure - Storage adapters"

Schermata del controller di storage mancante

2 - Quando si passa a "Cluster - Configure - vSAN - Disk management" e "Disks in use" uno degli host mostra 0/0.
Schermata di 0/0 dischi in uso 

3 - Accedere a "iDRAC - Storage - Controllers" e il controller è lì.
Il controllore viene visualizzato nell'iDRAC 

4 - Anche in "iDRAC - Storage - Physical disks" sono presenti tutti i dischi.
Tutti i dischi vengono visualizzati in iDRAC 

5 - Ti connetti all'host tramite SSH ed esegui "esxcli storage core adapter list" e vmhbaX (nel nostro caso è vmhab0) manca.

[root@vxrail01:~] esxcli storage core adapter list
HBA Name  Driver     Link State  UID                                     Capabilities         Description
--------  ---------  ----------  --------------------------------------  -------------------  -----------
vmhba1    vmw_ahci   link-n/a    sata.vmhba1                                                  (0000:00:11.5) Intel Corporation Lewisburg SATA AHCI Controller
vmhba2    vmw_ahci   link-n/a    sata.vmhba2                                                  (0000:00:17.0) Intel Corporation Lewisburg SATA AHCI Controller
vmhba3    vmw_ahci   link-n/a    sata.vmhba3                                                  (0000:3b:00.0) Marvell Technology Group Ltd. Dell BOSS-S1 Adapter
vmhba64   vmkfcoe    link-down   fcoe.1000000c2902a258:2000000c2902a258  Second Level Lun ID  VMware Inc Software FCoE Adapter
vmhba65   iscsi_vmk  online      iscsi.vmhba65                           Second Level Lun ID  iSCSI Software Adapter

6 - Quando si elencano i dispositivi PCI utilizzando "lspci | grep -i hba", il PERC/HBA

[root@vxrail01:~] lspci | grep -i hba
0000:00:11.5 SATA controller: Intel Corporation Lewisburg SATA AHCI Controller [vmhba1]
0000:00:17.0 SATA controller: Intel Corporation Lewisburg SATA AHCI Controller [vmhba2]
0000:18:00.0 RAID bus controller: Broadcom PERC H330 Mini [vmhba0]
0000:3b:00.0 SATA controller: Marvell Technology Group Ltd. Dell BOSS-S1 Adapter [vmhba3]

7 - Controllare le proprietà dell HBA eseguendo "lspci -p | grep -i vmhbaX".

[root@vxrail01:~] lspci -p | grep -i vmhba0
0000:18:00.0 1000:005f 1028:1f4b 255/   /     A P pciPassthru  vmhba0

In questo caso, come possiamo vedere, il vmhba0 è impostato su "pciPassthru", questo è il problema.

Causa

Ciò si verifica quando qualcuno abilita il passthrough PCI sull HBA responsabile dei dischi vSAN.

Risoluzione

1 - Cliccare sull host in cui l'HBA non viene visualizzato. Passare a "Configure - Hardware - PCI Devices"; nella scheda "PASSTHROUGH-ENABLED DEVICES" viene visualizzato l'HBA che presenta problemi. Selezionalo e clicca su "TOGGLE PASSTHROUGH"

Attiva/disattiva passthrough

Prodotti interessati

VxRail, VxRail 460 and 470 Nodes, VxRail Appliance Series, VxRail G Series Nodes, VxRail D Series Nodes, VxRail D560, VxRail D560F, VxRail E Series Nodes, VxRail E460, VxRail E560, VxRail E560F, VxRail E560N, VxRail E660, VxRail E660F, VxRail E660N , VxRail E665, VxRail E665F, VxRail E665N, VxRail G560, VxRail G560F, VxRail P Series Nodes, VxRail P570, VxRail P570F, VxRail P580N, VxRail P670F, VxRail P670N, VxRail P675F, VxRail P675N, VxRail S Series Nodes, VxRail S470, VxRail S570, VxRail S670, VxRail Software, VxRail V Series Nodes, VxRail V470, VxRail V570, VxRail V570F, VXRAIL V670F, VxRail VD-4510C, VxRail VD-4520C, VxRail VD Series Nodes, VxRail VE-660, VxRail VE-6615, VxRail VE-670, VxRail VP-760, VxRail VP-7625, VxRail VP-770, VxRail VS-760 ...
Proprietà dell'articolo
Numero articolo: 000212003
Tipo di articolo: Solution
Ultima modifica: 06 mar 2026
Versione:  4
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.