PowerProtect Data Manager 19.12 e versioni precedenti: Utilizzo elevato della CPU da parte del servizio agent

Riepilogo: Elevato utilizzo della CPU (Central Processing Unit) da parte del processo del sistema operativo (OS) del servizio agente.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Il sistema operativo di un host mostra un elevato utilizzo della CPU quando è in esecuzione PowerProtect Data Manager 19.12 o versioni precedenti.

Non sono presenti sintomi visibili nei registri, ma il comportamento si verifica nell'applicazione Gestione attività dell host.

Causa

Esistono due cause note per il comportamento dei picchi della CPU:

  1. Il file tasks.db deve ricaricarsi per ogni iterazione. Se è grande, ogni volta che ciò accade, provoca un picco nell'utilizzo della CPU.
  2. La versione 19.11 utilizza una chiamata API (Application Programming Interface) lockbox per ogni chiamata API della sessione GET.

Questa chiamata API lockbox consuma più CPU del normale. Il polling per un'API di sessione GET viene eseguito ogni 30 secondi.
In questa richiesta è presente una chiamata non necessaria che tenta di decrittografare la password ogni volta.  

Risoluzione

Versioni interessate: Questo problema interessa v19.12 e versioni precedenti.

Soluzione alternativa: 

  1. Arrestare il servizio agent.
  2. Rinominare il tasks.db in C:\Program Files\DPSAPPS\AgentService\dbs\v1.
  3. Riavviare il servizio agent.

Versione fissa: Il problema non è presente nella v19.13 e versioni successive.

 

Prodotti interessati

PowerProtect Data Manager, PowerProtect Software
Proprietà dell'articolo
Numero articolo: 000212583
Tipo di articolo: Solution
Ultima modifica: 06 ott 2025
Versione:  3
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