PowerProtect: I container Docker di Cyber Recovery non si avviano e "Impossibile connettersi al daemon Docker"
Riepilogo: Il cliente non è in grado di utilizzare Cyber Recovery a causa dei container docker che non possono avviarsi a causa del daemon docker non in esecuzione.
Questo articolo si applica a
Questo articolo non si applica a
Questo articolo non è legato a un prodotto specifico.
Non tutte le versioni del prodotto sono identificate in questo articolo.
Sintomi
Quando si tenta di eseguire Docker PS, viene visualizzato un messaggio che chiede se il daemon Docker è in esecuzione.
Il servizio Docker non è attivo
[root@hostname ~]# docker ps -a Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?
Il servizio Docker non è attivo
[root@hostname ~]# systemctl status docker
? docker.service - Docker Application Container Engine
Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled; vendor preset: disabled)
Active: failed (Result: start-limit) since Wed 2022-11-16 07:39:05 EST; 3min 34s ago
Docs: https://docs.docker.com
Main PID: 7590 (code=exited, status=1/FAILURE)
Nov 16 07:39:02 hostname systemd[1]: docker.service failed.
Nov 16 07:39:05 hostname systemd[1]: docker.service holdoff time over, scheduling restart.
Nov 16 07:39:05 hostname systemd[1]: Stopped Docker Application Container Engine.
Nov 16 07:39:05 hostname systemd[1]: start request repeated too quickly for docker.service
Nov 16 07:39:05 hostname systemd[1]: Failed to start Docker Application Container Engine.
Nov 16 07:39:05 hostname systemd[1]: Unit docker.service entered failed state.
Nov 16 07:39:05 hostname systemd[1]: docker.service failed.
Nov 16 07:39:40 hostname systemd[1]: start request repeated too quickly for docker.service
Nov 16 07:39:40 hostname systemd[1]: Failed to start Docker Application Container Engine.
Nov 16 07:39:40 hostname systemd[1]: docker.service failed.
Causa
Quando si tenta di avviare il daemon Docker, viene visualizzato un messaggio di avvertenza di un problema di spazio
Si è verificato un problema di spazio su disco. Il file system root sembra essere pieno:
[root@ hostname]# sudo dockerd Error starting daemon: Unable to get the TempDir under /var/lib/docker: mkdir /var/lib/docker/tmp: no space left on device
Si è verificato un problema di spazio su disco. Il file system root sembra essere pieno:
[root@hostname ~]# df -kh Filesystem Size Used Avail Use% Mounted on /dev/mapper/centos_hostname-root 38G 38G 20K 100% / <<<< devtmpfs 1.9G 0 1.9G 0% /dev tmpfs 1.9G 8.0K 1.9G 1% /dev/shm tmpfs 1.9G 8.9M 1.9G 1% /run tmpfs 1.9G 0 1.9G 0% /sys/fs/cgroup /dev/sda1 1014M 189M 826M 19% /boot /dev/mapper/centos_ehs--hostname-home 19G 3.0G 16G 17% /home tmpfs 379M 0 379M 0% /run/user/0 [root@hostname ~]#
Risoluzione
Dopo aver richiesto spazio rimuovendo alcuni pacchetti e pacchetti di supporto precedenti per le versioni precedenti non più necessari, riavviare la macchina virtuale Cyber Recovery. I container erano ora di nuovo in esecuzione e il cliente è stato in grado di riprendere l'utilizzo di Cyber Recovery.
Prodotti interessati
Cyber Recovery SeriesProdotti
Cyber Recovery Series, CyberSenseProprietà dell'articolo
Numero articolo: 000214296
Tipo di articolo: Solution
Ultima modifica: 04 nov 2025
Versione: 2
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.