Windows Server: Klyngeformet virtuel maskine mangler i failover Cluster Manager

Riepilogo: En virtuel maskine (VM) i en Windows Server Hyper-V-klynge vises muligvis ikke som forventet i Failover Cluster Manager.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Mindst én VM med klynger er ikke angivet under fanen Roller i Failover Cluster Manager. Den pågældende VM vises i Hyper-V Manager på en af klyngenoderne. Hyper-V Manager angiver dog, at nogle af VM'ens indstillinger ikke kan ændres, fordi den er grupperet.

Causa

Dette kan forekomme, hvis VM'ens viste navn er ændret, siden den blev oprettet.

Risoluzione

Den berørte VM vises muligvis under fanen Roller under et andet navn. Dette er mere sandsynligt i en klynge, der hoster mange VM'er, end en, der kun hoster nogle få. Følg disse trin for at afgøre, om dette er tilfældet:

  1. På en klyngenode skal du starte en PowerShell-prompt med administratorrettigheder.
  2. Kør kommandoen:
Get-ClusterResource
  1. Kontrollér kolonnen Navn for outputtet for den berørte VM.
  2. Hvis den berørte VM er angivet i outputtet, findes den i klyngen.
  3. Navnet i kolonnen Ejergruppe viser det navn, som VM'en vises under i Failover Cluster Manager. Bekræft om nødvendigt, at det er den korrekte VM ved at oprette forbindelse til den.
  4. I Failover Cluster Manager skal du højreklikke på VM'en (ved hjælp af navnet vist i trin 5) og vælge Egenskaber.
  5. Ret VM'ens visningsnavn, og klik på OK. Det skulle nu være angivet som forventet.

Prodotti interessati

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022

Prodotti

PowerEdge FC640, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX5016s, PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360 , PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Proprietà dell'articolo
Numero articolo: 000216625
Tipo di articolo: Solution
Ultima modifica: 16 dic 2024
Versione:  5
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.