Avamar: "vSphere Task failed" 오류와 함께 간헐적인 가상 머신 이미지 백업 실패

Riepilogo: 다음 오류가 있는 간헐적인 VM(Virtual Machine) 이미지 백업 실패 "vSphere Task failed (snapshot error=45): 가용 장애 도메인은 두 개입니다. 이 작업을 수행하려면 가용 장애 도메인이 하나 더 필요합니다." 오류 메시지가 나타납니다.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

스냅샷 생성 단계에서 백업이 실패하고 다음 오류가 발생합니다.

2023-08-06 23:06:32 avvcbimage Error <44034>: vSphere Task failed (snapshot error=45): 'There are currently 2 usable fault domains. The operation requires 1 more usable fault domains.'.
2023-08-06 23:06:32 avvcbimage Error <44020>: Snapshot 'Avamar-169136317118b22ef41ebc7a87342f2790f581058cfa460bfd' creation for VM '[VxRail-Virtual-SAN-Datastore-xxxx-xxxx-xx] xxx-xxxx-xxx/vm_name.vmx' task creation encountered a problem

이 문제는 VxRail에서 관리하는 vSAN 데이터 저장소에 상주하는 임의의 VM에서 산발적으로 발생합니다.

위와 동일한 오류 메시지가 vSphere UI에 표시됩니다.

Create Snapshot message: There are currently 2 usable fault domains. The operation requires 1 more usable fault domains.
--> An error occurred while taking a snapshot: Out of resources.

vSphere UI 오류

Causa

VxRail은 "장애 도메인"이라는 개념을 사용합니다. vSAN의 장애 도메인은 vSAN 클러스터의 회복탄력성을 개선하기 위한 선택적 구성입니다. 단일 호스트 또는 여러 호스트에 장애가 발생하거나 사용할 수 없는 경우에도 클러스터의 데이터를 계속 사용할 수 있습니다.

다음 VMware KB 기준: 특정 스토리지 정책의 필요한 최소 호스트 수가 온라인 상태일 때 VM의 스냅샷을 생성할 수 없습니다. vSAN은 스토리지 정책을 충족하기 위해 최소 수의 호스트가 필요합니다.이 하이퍼링크는 Dell Technologies 외부의 웹사이트로 연결됩니다. 이러한 호스트 중 하나를 사용할 수 없게 되면 적용된 스토리지 정책을 충족할 만큼 리소스가 충분하지 않기 때문에 vSAN에서 새 개체의 프로비저닝을 허용하지 않습니다.

이 백업 실패의 근본 원인 분석은 vSAN Witness 호스트가 백업 정책에 있음을 나타냅니다. 스냅샷 작업으로 인해 위의 불일치가 발생하여 위의 오류가 있는 실행 중인 다른 백업에 영향을 줄 수 있으므로 Witness 호스트를 백업하지 않는 것이 좋습니다.

Risoluzione

백업 정책에서 vSAN 감시 호스트를 제외합니다.

Prodotti interessati

Avamar, Avamar Client for VMware
Proprietà dell'articolo
Numero articolo: 000218580
Tipo di articolo: Solution
Ultima modifica: 17 dic 2025
Versione:  4
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.