NVP vProxy:RHEL 9 Linux VM 不會在 FLR 期間顯示某些資料夾。

Riepilogo: 在 Red Hat 9.x 虛擬機器上執行 VM FLR。掛接作業成功,但在 FLR 流覽作業期間看不到某些資料夾。使用者介面未報告任何錯誤。虛擬機器是使用 LVM 分割區進行設定。

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

  • NetWorker VMware 解決方案是使用 NetWorker VMware Protection (NVP) vProxy 應用裝置進行設定。
  • 為 Linux VM 執行檔案層級還原 (FLR)。FLR 掛載作業已成功完成;但是,在流覽作業期間,只會顯示部分系統資料夾:
NMC 還原精靈 FLR 流覽視窗
  • 無論使用 NetWorker 管理主控台 (NMC) 或 NetWorker Web 使用者介面 (NWUI),以及當 VM 的根使用者帳戶用於執行 FLR 掛接時,都會出現此問題。
  • VM 的 /opt/emc/vproxyra/logs/vflragentd/vflragentd-agent.log 報告:
YYYY-MM-DDTHH:mm:SS-TZ INFO:   Mount #6: HH:mm:SS Mounting LVM volumes...
YYYY-MM-DDTHH:mm:SS-TZ INFO:   Mount #6: HH:mm:SS Running command: /sbin/lvm pvs --config 'global { use_lvmetad = 0 }' -o vg_name,pv_name --noheadings --separator : '/dev/sdc3' 2>&1
YYYY-MM-DDTHH:mm:SS-TZ INFO:   Mount #6: HH:mm:SS -->   Cannot use /dev/sdc3: device is not in devices file
  • VM 為 Red Hat 9.x 版本 (或更新版本)
  • vProxy 應用裝置為 4.3.0-38 或更舊版本。

Causa

虛擬機器是使用 LVM 分割區進行設定。vProxy 需要變更程式碼,以支援 RHEL 9LVM。

Risoluzione

將 vProxy 應用裝置升級至 4.3.0-39 或更新版本。vProxy 升級到 4.3.0-39 或更新版本後,請再次執行 FLR,在流覽作業期間會顯示 LVM 分割區:

NVP vProxy:如何使用 nsrvproxy_mgmt 升級 NVP vProxy 應用裝置

Informazioni aggiuntive

Linux lsblk 命令可用來識別使用 LVM 裝置的檔案系統掛載點。

[root@lnx-client03]:~# lsblk
NAME          MAJ:MIN RM  SIZE RO TYPE MOUNTPOINTS
sda             8:0    0   30G  0 disk
├─sda1          8:1    0  600M  0 part /boot/efi
├─sda2          8:2    0    1G  0 part /boot
└─sda3          8:3    0 28.4G  0 part
  ├─rhel-root 253:0    0 25.4G  0 lvm  /
  └─rhel-swap 253:1    0    3G  0 lvm  [SWAP]
sr0            11:0    1 1024M  0 rom

Prodotti interessati

NetWorker

Prodotti

NetWorker Family, NetWorker Series
Proprietà dell'articolo
Numero articolo: 000219868
Tipo di articolo: Solution
Ultima modifica: 28 mar 2025
Versione:  3
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.