Containerlagringsmoduler Operatorn visar statusen Failed när observerbarhet eller programmobilitet distribueras med en drivrutin

Riepilogo: I Container Storage Modules 1.8.0, när Observability eller Application Mobility distribueras med en drivrutin, anger Container Storage Modules Operator inte statusen korrekt. Om modulen misslyckas visas statusen "Lyckades", vilket är fel. ...

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Systemet verifierar inte status för CSM korrekt när en felaktig modulavbildning installeras med en drivrutin. Statusen anges till "Lyckades", men modulen distribueras inte.
kubectl get csm -A
NAMESPACE  NAME       CREATIONTIME CSIDRIVERTYPE CONFIGVERSION STATE
vxflexos          vxflexos    3m14s                 Powerflex           v2.9.0                    Failed    
Showing correct CSM status after code changes:
NAMESPACE  NAME       CREATIONTIME CSIDRIVERTYPE CONFIGVERSION STATE
vxflexos          vxflexos    3m14s                 Powerflex           v2.9.0                    Succeeded

Causa

Statuskoden för operatören söker inte efter lyckade moduler, resultatet av statuskontrollen baseras endast på drivrutinens status.

Den länkade linjen söker endast efter programmobilitet, men fungerar inte när den installeras tillsammans med drivrutinen eller andra moduler https://github.com/dell/csm-operator/blob/e135454e5df50402c4080ed94e5303228b869167/pkg/utils/status.go#L350Den här hyperlänken tar dig till en webbplats utanför Dell Technologies.

Risoluzione

Teknikerna har löst det här problemet i Container Storage Modules 1.9.1 och Container Storage Modules Operator 1.4.1. Operatörskoden uppdateras för att kontrollera programmobilitet och observerbarhet.

Prodotti

Container Storage Modules Family, Container Storage Modules
Proprietà dell'articolo
Numero articolo: 000221761
Tipo di articolo: Solution
Ultima modifica: 03 set 2025
Versione:  4
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.