liste S3 bøtte objekter løkker uendelig ved hjelp av API ListObjects eller ListObjectsV2

Riepilogo: S3 App eller s3cmd bruker S3 API listobject eller listobjectv2 til å spørre objekter fra s3-bøtte, i noen hjørnetilfeller returnerer Powerscale OneFS s3 feil resultat hvis dirCache er der, men det oppfyller ikke forespørselen, S3-appen henger på grunn av listeobjekter som treffer uendelig løkke. ...

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

S3 App bare henger på grunn av notering en bøtte kan ikke fullføre.
S3cmd ls bøtte gjentatte ganger få de samme objektene returnert i en paginert liste.

Causa

Dette kan treffe en s3 cache bug # PSCALE-217613. 
 
Hvis klienten ber ListObjects med maks oppføring = 1000, internt får vi 10.000 oppføringer (hvis katalogen er svært bred) og returnere 1000 av dem til klienten, og deretter gjenbruke resterende 9000 for fremtidig forespørsel. På neste forespørsel, hvis det er en cache, og det fortsatt er filer under katalogen som ennå ikke er returnert til klienten, og gjeldende cache ikke har nok oppføring for å oppfylle forespørselen, treffer vi en feil og returnerer feil resultat.

Risoluzione

Teknisk avdeling jobber med den permanente løsningen, og RUP-oppdateringen vil bli lansert når den er klar. 
Den nåværende løsningen er å konfigurere s3 ls DIR_CACHE_TTL til 0 midlertidig: 
# isi_for_array -X  "/usr/likewise/bin/lwsm inject s3 s3_ls_set_dir_cache_ttl on 0"

Hvis s3-prosessen starter på nytt eller en node startes på nytt, må du bruke løsningen på noden siden den har blitt tilbakestilt til standard 1 time da s3 startet på nytt. 
Slik deaktiverer du manuell DIR_CACHE_TTL
#isi_for_array -X  "/usr/likewise/bin/lwsm inject s3 s3_ls_set_dir_cache_ttl off"

Prodotti interessati

Isilon, PowerScale
Proprietà dell'articolo
Numero articolo: 000223936
Tipo di articolo: Solution
Ultima modifica: 11 giu 2024
Versione:  3
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.