Connectrix: MDS: Kullanıcıları Göster Komutu Yanlış Bir Tarih ve Saat Görüntülüyor Yalnızca 1 Ocak 08:00
Riepilogo: Show Users komutu, sistemde oturum açan kullanıcılar hakkında bilgi sağlar. Bu makalede, tarih ve saatin yanlış gösterilmesine neden olan bir sorun açıklanmaktadır.
Questo articolo si applica a
Questo articolo non si applica a
Questo articolo non è legato a un prodotto specifico.
Non tutte le versioni del prodotto sono identificate in questo articolo.
Sintomi
Anahtar NX-OS 9.4.1a'da çalışır.
Users komut çıktısı, aşağıda gösterildiği gibi yanlış bir zaman damgası görüntüler:
Users komut çıktısı, aşağıda gösterildiği gibi yanlış bir zaman damgası görüntüler:
[Model 9132T on NX-OS 9.4.1a] =================== MDS9132T-s1fA-sw3# show version system: version 9.4(1a) <<<<<<<<<<<<<<<<<<< 9.4.1a system image file is: bootflash:///m9100-s6ek9-mz.9.4.1a.bin system compile time: 12/25/2023 12:00:00 [01/12/2024 10:45:51] Reason: Reload due to non-disruptive system reload MDS9132T-s1fA-sw3# sh clock Time source is Hardware Calendar 09:55:11.833 IST Sat Jun 15 2024 MDS9132T-s1fA-sw3# show users NAME LINE TIME IDLE PID COMMENT admin pts/0 Jan 1 05:30 . 16852 session=ssh * <<<<<<<<<<<< Jan 1 05:30
Causa
Bunun nedeni, NX-OS 9.4.1a'yı etkileyen bir Cisco Kusur Kimliği CSCWK43183 olmasıdır.
Risoluzione
NX-OS sürüm 9.4(1a)'da,
O zamandan beri
Geçi -ci çözüm:
Düzeltmek:
NX-OS 9.4.2 sürümüne yükseltin.
show users komutu, yapılandırılan saat dilimine bağlı olarak UTC'den saat farkıyla birlikte sürekli olarak 1 Ocak'ı görüntüler.
O zamandan beri
show users Çıktı yanlış bir zaman damgası görüntüler. show accounting log Yönetici kullanıcı için en son oturum açma zaman damgası kontrol edilebilir.
Geçi -ci çözüm:
When a user logs in to the switch on SSH, accounting log records the login of the user as below: <timestamp> :type=start:id=10.138.65.80@pts/1:user=admin:cmd= When a user logs into the switch on console, accounting log records the login of the user as below: <timestamp> :type=start:id=console0:user=admin:cmd= To view the last logged in time for a user named "admin", run the below command: # show accounting log | grep "start.*admin" | tail lines 1
Düzeltmek:
NX-OS 9.4.2 sürümüne yükseltin.
DS9132T-s1fA-sw3# show version | grep sys system: version 9.4(2) <<<<<<<<<<<<<<<<<<<<< 9.4.2 system image file is: bootflash:///m9100-s6ek9-mz.9.4.2.bin system compile time: 4/25/2024 12:00:00 [05/10/2024 03:55:39] MDS9132T-s1fA-sw3# sh users NAME LINE TIME IDLE PID COMMENT admin pts/0 Jun 15 10:16 . 6362 (10.1xx.x5.1x5) session=ssh * >>>> showing correct timings After downgrading the switch from version 9.4.1a to 9.3.2a, the timestamps displayed by the 'show users' command are now correct. BIOS compile time: 05/16/2023 kickstart image file is: bootflash:///m9300-s1ek9-kickstart-mz.9.3.2a.bin <<<< kickstart compile time: 4/25/2023 12:00:00 [05/13/2023 03:09:36] system image file is: bootflash:///m9300-s1ek9-mz.9.3.2a.bin system compile time: 4/25/2023 12:00:00 [05/13/2023 04:28:40] MDS9396S-s1fB-SW1# show users NAME LINE TIME IDLE PID COMMENT admin pts/0 Jun 15 15:41 . 4855 (10.1xx.2xx.x8) session=ssh * <<<< show users displaying the correct time. MDS9396S-s1fB-SW1# show clock Time source is NTP 15:42:36.016 ist Sat Jun 15 2024
Not:
9.4.2 sürümüne yükseltme yapmadan önce, TACACS'ın anahtarlarınızda kimlik doğrulama protokolü olarak kullanılıp kullanılmadığını doğrulayın.
9.4.2 sürümüne yükseltme yapmadan önce, TACACS'ın anahtarlarınızda kimlik doğrulama protokolü olarak kullanılıp kullanılmadığını doğrulayın.
- Cevap evet ise Cisco hata CSCWK14579, 9.4.2'ye yükseltmeden sonra kimlik doğrulama hatalarına neden olabilir. Bu nedenle, TACACS'ı devre dışı bırakın ve bellenim yükseltmesini gerçekleştirin. Ardından TACACS yapılandırmasını etkinleştirin.
- Anahtarlar kimlik doğrulama için TACACS kullanmıyorsa, herhangi bir sorun olmadan 9.4(2) sürümüne yükseltebilirsiniz.
Prodotti
VxBlock and Vblock SystemsProprietà dell'articolo
Numero articolo: 000226156
Tipo di articolo: Solution
Ultima modifica: 01 gen 2026
Versione: 3
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.