Appliance PowerProtect Data Manager [DM5500]: Accesso utente AD con "NGINX 500 internal server error"

Riepilogo: Quando un utente con numerosi gruppi Active Directory (AD) accede all'interfaccia web di DM5500, potrebbe riscontrare un "errore interno del server 500". La risoluzione permanente è in DM5500 versione 5.17.0.0 o successiva. ...

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Sintomi

Se il profilo AD di un utente dispone di molti gruppi associati, l'utente potrebbe riscontrare un "errore interno del server 500" durante la connessione all'interfaccia utente di DM5500.
Un errore interno del server 500 dal web browser
Figura 1. "500 Internal Server Error" dal web browser

 

Nella error.log NGINX di PowerProtect Data Manager (PPDM), è possibile riscontrare un errore simile al seguente:

2024/04/24 05:31:46 [error] 82#82: *507187 upstream sent too big header while reading response header from upstream, client: xxx.xxx.xxx.xxx, server: ppoe, request: "GET / HTTP/1.1", subrequest: "/_iam_auth_internal", upstream: "http://xxx.xxx.xxx.xxx:8080/iam-token-handler/private/add-auth-header", host: "xxx.xxx.xxx.xxx"

 

Causa

In DM5500 versione 5.16.0.0 o precedente, un utente AD appartenente a molti gruppi può generare un'intestazione di payload API (Application Programming Interface) sovradimensionata che il servizio NGINX non è in grado di gestire.

 

Risoluzione

La risoluzione permanente è in DM5500 versione 5.17.0.0 o successiva.

 

Prodotti interessati

PowerProtect Data Manager Appliance, PowerProtect DM5500
Proprietà dell'articolo
Numero articolo: 000226158
Tipo di articolo: Solution
Ultima modifica: 05 ago 2025
Versione:  2
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