Appliance PowerProtect Data Manager [DM5500]: Accesso utente AD con "NGINX 500 internal server error"
Riepilogo: Quando un utente con numerosi gruppi Active Directory (AD) accede all'interfaccia web di DM5500, potrebbe riscontrare un "errore interno del server 500". La risoluzione permanente è in DM5500 versione 5.17.0.0 o successiva. ...
Questo articolo si applica a
Questo articolo non si applica a
Questo articolo non è legato a un prodotto specifico.
Non tutte le versioni del prodotto sono identificate in questo articolo.
Sintomi
Se il profilo AD di un utente dispone di molti gruppi associati, l'utente potrebbe riscontrare un "errore interno del server 500" durante la connessione all'interfaccia utente di DM5500.
Figura 1. "500 Internal Server Error" dal web browser
Nella error.log NGINX di PowerProtect Data Manager (PPDM), è possibile riscontrare un errore simile al seguente:
2024/04/24 05:31:46 [error] 82#82: *507187 upstream sent too big header while reading response header from upstream, client: xxx.xxx.xxx.xxx, server: ppoe, request: "GET / HTTP/1.1", subrequest: "/_iam_auth_internal", upstream: "http://xxx.xxx.xxx.xxx:8080/iam-token-handler/private/add-auth-header", host: "xxx.xxx.xxx.xxx"
Causa
In DM5500 versione 5.16.0.0 o precedente, un utente AD appartenente a molti gruppi può generare un'intestazione di payload API (Application Programming Interface) sovradimensionata che il servizio NGINX non è in grado di gestire.
Risoluzione
La risoluzione permanente è in DM5500 versione 5.17.0.0 o successiva.
Prodotti interessati
PowerProtect Data Manager Appliance, PowerProtect DM5500Proprietà dell'articolo
Numero articolo: 000226158
Tipo di articolo: Solution
Ultima modifica: 05 ago 2025
Versione: 2
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.