L'implementazione o l'aggiornamento del motore di reporting di PowerProtect Data Manager alla versione 19.17 potrebbe non riuscire

Riepilogo: L'implementazione o l'aggiornamento di PowerProtect Data Manager Reporting Engine alla versione 19.17 potrebbe non riuscire.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Quando si implementa un nuovo motore di reporting o si aggiorna un engine di reporting alla versione 19.17, l'implementazione\aggiornamento avrà esito negativo se il nodo di reporting è stato configurato con 3 voci DNS.
 

Verrà registrato il seguente errore per deployment\upgrade non riuscito:

Node configuration failed.
Failed to start the report service.


Nel reporting-service.log vengono rilevati i seguenti errori:

2024-08-09T14:13:27.875Z INFO [PID_IS_UNDEFINED] [main] [c.e.a.common.util.Util.isCertsConfigured(44)] -  Is certificates configured  false  

2024-08-09T14:13:27.875Z ERROR [PID_IS_UNDEFINED] [main] [c.e.c.s.CoreStartupApplication.init(44)] -  Not able to initialize services, missing required certificates. 


Se si utilizzano solo 1 o 2 voci DNS, il deployment\upgrade avrà esito positivo.

Causa

Il processo di generazione del certificato ha esito negativo perché non è in grado di eseguire una ricerca NSLOOKUP dell'indirizzo IP del nodo di reporting PowerProtect per ottenere il nome FQDN.

Durante l'esecuzione di qualsiasi NSLOOKUP sul nodo di reporting, verrà generato il seguente errore:

ppreportingengine:# nslookup 10.10.0.42

nslookup: parse of /etc/resolv.conf failed 


L'errore è causato dal contenuto del file /etc/resolv.conf. Invece di avere voci separate per ogni indirizzo IP DNS (ad esempio primario, secondario e terziario), le voci DNS secondarie e terziarie sono state unite e separate da una virgola:

nameserver 192.168.9.100
nameserver 192.168.9.1,192.168.9.2

Risoluzione

Dell Technologies consiglia agli utenti di eseguire l'upgrade a versioni di PowerProtect Data Manager successive alla 19.17.0-10.

Per risolvere il problema, contattare il supporto tecnico Dell per assistenza.
Proprietà dell'articolo
Numero articolo: 000228160
Tipo di articolo: Solution
Ultima modifica: 30 ago 2024
Versione:  1
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.