Connectrix Cisco MDS: Impossibile installare il codice di attendibilità quando lo switch è connesso direttamente a CSM

Riepilogo: Topologia 2: Connesso direttamente a CSSM. In questo tipo di connessione, viene stabilita una connessione diretta e affidabile da uno switch a CSM. La connessione diretta richiede la raggiungibilità della rete a CSM. Lo switch è configurato con tipo di trasporto "call home". ...

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Il codice di attendibilità installato mostra "<none>" e non riesce ad aggiornare il proprio stato in "Show license status" senza alcun errore in "Show logging log".
`show license status`
Utility: 
    Status: DISABLED

Smart Licensing using Policy:
    Status: ENABLED

Data Privacy: 
    Sending Hostname: yes 
    Callhome Hostname Privacy: DISABLED 
        Smart Licensing Hostname Privacy: DISABLED 
    Version Privacy: DISABLED 

Transport: 
    Type: Callhome
.
.
.
Trust Code installed: <none>  >> The trust code status shows none.

Causa

Il CSM non è raggiungibile e il tipo di trasporto configurato è CallHome.
Utilizzare il comando seguente per verificare se l'URL è configurato esattamente come segue: https://tools.cisco.com/its/service/oddce/services/DDCEService.

 show license status

 

Switch : san002
callhome
  email-contact <Company email ID>
  streetaddress <Site address>
  distribute
  destination-profile full_text
  destination-profile full_text format XML
  destination-profile full_text message-size 100000
  destination-profile test
  destination-profile test format XML
  destination-profile test message-level 5
  destination-profile xml transport-method http
  destination-profile xml message-level 2
  .
  .
  .
  destination-profile xml http https://tools.cisco.com/its/service/oddce/services/DDCEService > this URL configuraion should be present in callhome config.
  destination-profile test alert-group system
  transport email from <Company email ID>
  transport email reply-to <Company email ID>

Risoluzione

Configurare l'URL e verificare che la configurazione call home venga aggiornata con l'URL.
switch# configure terminal
switch(config)# ip domain-lookup
switch(config)# ip domain-name cisco.com
switch(config)# ip name-server 171.70.xx.xx
switch(config)# callhome
switch(config-callhome)# dest xml trans http
switch(config-callhome)# dest xml email sl-sch-test@cisco.com
switch(config-callhome)# dest xml http https://tools.cisco.com/its/service/oddce/services/DDCEService
switch(config-callhome)# enable
switch(config-callhome)# commit*
switch(config-callhome)# exit
switch(config)# feature license smart
Assicurarsi che il distributore CallHome sia abilitato. In caso contrario, il commit non riesce.
Una volta configurato l'URL, installare il codice di attendibilità utilizzando quanto segue: 
Eseguire il comando sullo switch:
switch# license smart trust idtoken id_token_value all
Il token ID deve essere copiato dal portale CSM nella scheda Inventory>General.
san002# show license status
Utility:
    Status: DISABLED
Smart Licensing using Policy:
    Status: ENABLED
Data Privacy:
    Sending Hostname: yes
    Callhome Hostname Privacy: DISABLED
        Smart Licensing Hostname Privacy: DISABLED
    Version Privacy: DISABLED
Transport:
    Type: Callhome
.
.
.
Trust Code installed: Sep  2 13:10:07 2024  UTC
    Active: PID: DS-C9706, SN: FXS24XXXXXX
        Sep  2 13:10:07 2024  UTC
    Standby: PID: DS-C9706, SN: FXS24XXXXXX
        Sep  2 13:10:07 2024  UTC

Informazioni aggiuntive

Prodotti

Connectrix MDS-Series Firmware
Proprietà dell'articolo
Numero articolo: 000228278
Tipo di articolo: Solution
Ultima modifica: 16 set 2024
Versione:  1
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.