PowerStore: Controllo integrità precedente all'upgrade per rilevare un problema di prenotazione SCSI-3 obsoleto

Riepilogo: Il PUHC (Pre-Upgrade Health Check) verifica la presenza di prenotazioni SCSI-3 non aggiornate nel sistema.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Il PUHC (Pre-Upgrade Health Check) verifica la presenza di prenotazioni SCSI-3 non aggiornate nel sistema.

Il controllo integrità di PowerStore (PUHC) potrebbe non riuscire a causa della prenotazione SCSI-3 con registrazione SCSI non valida o non corrispondente, con il seguente errore: 

Found stale SCSI3 reservations. Please contact your service provider. (off_release_stale_scsi3_reg_check). 

Error code: 0xE10050020204.

Il controllo integrità è un controllo PUHC non rilasciato contenuto nel thin package Health Check scaricato dal sito Driver e download Dell . Per informazioni sul thin package per il controllo integrità, consultare la sezione Informazioni aggiuntive. 

Esempio di controllo PUHC che rileva questo problema:

Controllo PUHC della prenotazione SCSI3 obsoleta

Causa

In situazioni normali, ogni volta che un host prenota una prenotazione SCSI-3 per un volume, devono essere presenti una o più registrazioni SCSI corrispondenti (a seconda del numero di percorsi dell host, ogni registrazione corrisponde a un I_T_L).

In rari casi, una registrazione SCSI viene cancellata, ma la prenotazione SCSI-3 corrispondente viene lasciata sul lato PowerStore, puntando alla registrazione SCSI cancellata. L'aggiornamento senza interruzioni alla versione 4.0.0.X di tali appliance potrebbe non riuscire durante la fase di handover SYM.

Risoluzione

Questo problema è stato risolto in PowerStoreOS versione 4.1.0.1 

Gli aggiornamenti da PowerStoreOS dalla versione 3.x alla 4.1.0.1+ non riscontrano questo problema. 

 

Il problema rilevato da questo PUHC è stato risolto con PowerStoreOS versione 4.0.1.3 e 4.1.0 (o successiva).

Soluzione alternativa:

Se il livello del codice di destinazione di un aggiornamento in sospeso è inferiore alla versione 4.1.0.1, seguire questa procedura:

Chiedi al cliente di eseguire le due azioni seguenti:

  1. Pianificare una finestra di manutenzione per l'NDU per ridurre al minimo la possibilità di nuove prenotazioni durante l'NDU. 
  2. Eseguire un aggiornamento in due passaggi da PowerStoreOS versione 3.0.x o dalle versioni da 3.2.x a 4.0.x eseguendo prima l'aggiornamento alla versione 3.6.x più recente.

Informazioni aggiuntive

Prodotti interessati

PowerStore
Proprietà dell'articolo
Numero articolo: 000246358
Tipo di articolo: Solution
Ultima modifica: 02 set 2025
Versione:  4
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.