PowerEdge: 인텔 NIC 및 SONiC 인터페이스 플래핑 문제

Riepilogo: 고객이 SONiC 4.4.0 스위치의 인텔 X710 NIC 및 PKR0R 트랜시버에서 인터페이스 플래핑 문제를 경험했습니다.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

서버 재부팅 또는 OIR 테스트 중에 인터페이스 플래핑이 발생하여 운영 중단이 발생합니다. 이 문제는 Intel X550 NIC를 Intel X710으로 교체한 후에도 지속되었습니다.

펌웨어, 드라이버 및 OS 버전:

  • 인텔 X710 NIC 펌웨어 버전: 22.5.7
  • 인텔 X710 NIC 드라이버 버전: 2.5.11.0
  • 인텔 E810 NIC 펌웨어 버전: 23.0.8
  • 인텔 E810 NIC 드라이버 버전: 2.5.11.0
  • 운영 체제 버전: SONiC 4.4.0

 

스위치 로그에서 인터페이스 플래핑 문제를 식별하려면 포트의 작동 상태가 자주 변경됨을 나타내는 반복 메시지를 찾습니다. 예:

NOTICE swss#orchagent: :- updatePortOperStatus: Port Eth1/1 oper state set from up to down
NOTICE swss#orchagent: :- updatePortOperStatus: Port Eth1/1 oper state set from down to up

 

NIC의 Dell 파트 번호:

  • 인텔 X710 NIC: Dell P/N K5V44
  • 인텔 E810 NIC: Dell P/N VK88G
  • Broadcom BCM57416 NIC: Dell P/N 3TM39

새 코드의 예상 시간: 하드웨어 교체를 통해 문제가 해결되었기 때문에 새 코드가 필요하지 않습니다.

 

Causa

PKR0R 트랜시버 요구 사항: PKR0R 트랜시버가 효과적으로 작동하려면 2W의 전력이 필요합니다.

인텔 X710 NIC는 PKR0R 트랜시버에 충분하지 않은 최대 1.5W의 전력을 제공하여 인터페이스 플래핑 문제를 일으킵니다.

 

Risoluzione

이 문제는 인텔 X710 NIC를 인텔 E810 NIC로 교체하여 인터페이스 플래핑을 제거함으로써 해결되었습니다.

 

해결 방법:
서버 재부팅 또는 케이블 교체 후 스위치 측에서 인터페이스를 종료했다가 다시 활성화합니다.
Broadcom BCM57416와 같은 대체 NIC를 사용하는 경우에도 랩 테스트 중에 플래핑 문제가 없는 것으로 나타났습니다.

OCP 카드: OCP 카드는 인텔 X710 NIC 및 PKR0R 트랜시버에서 나타나는 것과 동일한 호환성 문제에 취약하지 않은 다른 아키텍처를 사용하기 때문에 이 플래핑 문제의 영향을 받지 않습니다.

 

Prodotti interessati

Intel PRO Family of Adapters, PowerEdge R240, PowerEdge R340, PowerEdge R440, PowerEdge R540, PowerEdge R640, PowerEdge R6415, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R840, PowerEdge R940 , PowerEdge R940xa ...

Prodotti

PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R840, PowerEdge R940, PowerEdge R940xa
Proprietà dell'articolo
Numero articolo: 000274913
Tipo di articolo: Solution
Ultima modifica: 13 mag 2025
Versione:  2
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.