PowerEdge: Preparare l'host VMware ESXi abilitato per TPM alla modifica dell hardware per evitare la schermata viola

Riepilogo: Se gli host ESXi utilizzano Trusted Platform Module (TPM), questo articolo fornisce la procedura per cui l'host ESXi è ancora accessibile tramite SSH prima di eventuali modifiche hardware. ...

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Istruzioni

Sintomi:
Dopo aver eseguito la manutenzione dell hardware, inclusa la sostituzione dei componenti (ad esempio, batteria CMOS, CPU e così via), è possibile che si verifichino errori di schermata viola durante l'avvio del backup host.

Esempio di messaggio di diagnostica con schermata viola

Root cause:
A partire dalla versione 7.0u2, ESXi utilizza TPM 2.0 per proteggere le configurazioni di sistema tramite "sigillo TPM". È possibile accedere alla configurazione solo con lo stesso chip TPM utilizzato inizialmente.

Per evitare questa situazione, è necessario raccogliere la chiave di ripristino dagli host abilitati per la sicurezza TPM prima di eseguire la sostituzione.

Istruzioni:

  1. Accedere tramite SSH all host ESXi
  2. Verificare che il TPM sia installato e che "TPM Security" sia abilitato nel BIOS:
[root@host1:~] esxcli hardware trustedboot get
   Drtm Enabled: true
   Tpm Present: true
  1. Ottenere la chiave di ripristino eseguendo il comando riportato di seguito:
esxcli system settings encryption recovery list

Output dal tasto di comando


Nota: La chiave di ripristino è il secondo set di numeri mostrato: 16 gruppi, ciascuno contenente sei cifre, come evidenziato sopra

 

  1. Assicurarsi di salvare la chiave di ripristino in un luogo sicuro per un uso futuro.

Nota: Se la chiave di ripristino non è disponibile, l'unica opzione possibile consiste nel reinstallare ESXi.

 

A questo punto, sostituisci in modo sicuro il componente e, se in precedenza era visualizzata la schermata viola, segui i passaggi seguenti per risolvere il problema.

Passi:

  1. Riavviare ESXi, quindi premere MAIUSC+O quando richiesto:

Schermata di riavvio

  1. Aggiungere la configurazione di avvio con quanto segue dalla chiave di ripristino raccolta da Prerequisiti: 
encryptionRecoveryKey=######-######-######-######-######-######-######-######-######-######-######-######-######

 

Nota: Non rimuovere le informazioni già presenti all'inizio del prompt.
 
Al termine dell'UUID di avvio esistente, aggiungere uno spazio seguito dalle informazioni encryptionRecoveryKey , come mostrato nella schermata precedente.
  1. Premere Enter per continuare il processo di avvio dell host.
  2. Connettersi con SSH all host ed eseguire il comando riportato di seguito per scrivere le modifiche su disco:
[root@host1:~] /sbin/auto-backup.sh

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Prodotti

C Series, Modular Infrastructure, Rack Servers, Tower Servers, XE Servers, XR Servers, OEM Server Solutions
Proprietà dell'articolo
Numero articolo: 000318876
Tipo di articolo: How To
Ultima modifica: 08 gen 2026
Versione:  3
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