L'audit log di PowerScale mostra 127.0.0.1 per S3

Riepilogo: Se si utilizzano le funzioni di audit (isi_audit) di PowerScale con bucket S3, è coinvolta una determinata funzionalità. Questa funzionalità influisce sulle operazioni S3 interne. Queste operazioni possono visualizzare 127.0.0.1 come indirizzo IP del client. ...

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Sintomi

 

Se si utilizzano le funzioni di audit (isi_audit) di PowerScale con bucket S3, viene attivata una funzionalità specifica. Fa sì che alcune operazioni S3 interne vengano visualizzate con 127.0.0.1 come indirizzo IP del client. Si tratta di un problema noto riscontrato inizialmente in OneFS 9.7.

Gli IP client 127.0.0.1 per alcune transazioni rappresentano il nodo OneFS in questione. Ogni nodo per S3 deve eseguire lavori di manutenzione relativi ai file utilizzati con i bucket S3. Se associato all'audit, può avere l'effetto collaterale dei payload dell'audit log visualizzati come client 127.0.0.1. Queste azioni sono diverse dalle azioni corrette dei protocolli controllate, come SMB, NFS o HDFS, che vengono comunque registrate correttamente dall'indirizzo IP del client. Le voci 127.0.0.1 sono "extra", a causa del problema, e rappresentano la manutenzione interna del contenuto S3. La correzione futura elimina queste voci 127.0.0.1 e la registrazione non necessaria di queste azioni interne.

 

Di seguito è riportato un esempio di stringa di payload di questo tipo:

 

ISI01-3: [1517065: Mon Jul 21 09:02:43 2025] {"id":"50e107ca-65f8-11f0-9327-f8f21e3acdbc","timestamp":1753077763170507,"payloadType":"c411a642-c139-4c7a-be58-93680bc20b41","payload":{"protocol":"S3","zoneID":1,"zoneName":"System","eventType":"create","detailType":"open-directory","createResult":"OPENED","isDirectory":true,"desiredAccess":32,"clientIPAddr":"127.0.0.1","createDispo":1,"userSID":"S-1-5-18","userID":0,"fileName":"\\ifs\\S3-ZONE\\xdr-common-loki\\index\\delete_requests","ntStatus":0,"fsId":1,"inode":4775883127,"S3OP":"put-object"}}

 

 

Notare l'area 127.0.0.1 in grassetto rosso. Ancora una volta, le tue vere azioni basate sul client stanno registrando bene nel frattempo. 

 

Causa

I sistemi di audit registrano erroneamente queste azioni interne che sono attività di manutenzione non rivolte al cliente sulla gestione del contenuto S3.

Risoluzione

Questo problema è stato risolto in una prossima versione di OneFS ed è stato confermato come difetto.

Prodotti interessati

Isilon

Prodotti

PowerScale OneFS
Proprietà dell'articolo
Numero articolo: 000401948
Tipo di articolo: Solution
Ultima modifica: 15 dic 2025
Versione:  1
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