メイン コンテンツに進む
  • すばやく簡単にご注文が可能
  • 注文内容の表示、配送状況をトラック
  • 会員限定の特典や割引のご利用
  • 製品リストの作成とアクセスが可能
  • 「Company Administration(会社情報の管理)」では、お使いのDell EMCのサイトや製品、製品レベルでのコンタクト先に関する情報を管理できます。

文書番号: 000201305


Windows Server環境で文字化けが発生する場合ある

概要: 本ドキュメントでは、Windows Server環境で文字化けが発生し文字が読み取れない場合の原因と対処方法について説明します。

文書の内容


現象

Windows Server環境において、文字化けの現象が発生すると、下記の画面ショットのような四角の枠だけの状況に陥り、文字が読み取れない状況になります。

 

image.png
image.png

 

原因

内部的に言語情報の不一致が発生していることで発生します。

 

解決方法

現在確認できている対象方法としては、以下の2点をいずれか、もしくは両方を実施することで現象が解消されることが確認できています。

  1. システムロケールを"英語"に変更し、その後"日本語"に戻す
  2. Windows Serverの表示言語を"英語"に変更し、その後"日本語"に戻す

 

システムロケールの変更

  1. コントールパネル -> 時計と地域 -> 地域をクリックします(アイコン表示の場合は地域をクリックしてください。)

  2. 管理タブをクリックします。

  3. システムロケールの変更をクリックします。

  4. 現在のシステムロケールを確認し、以下のように変更します。

    • 現在のシステムロケールが"英語"となっていた場合は"日本語(日本)"に変更します。
    • 現在のシステムロケールが"日本語(日本)"となっていた場合は、"英語(米語)"に変更します。(再起動後"日本語(日本)"に戻します。

  5. 地域の設定画面にてOKをクリックします。

  6. 再起動する必要があります画面で今すぐ再起動をクリックします。

  7. (手順4.で日本語から英語に変更した場合)再起動後、手順1.-5.の操作にてシステムロケールを日本語(日本)に戻しシステムを再起動します。
    *手順4.で英語から日本語に変更した場合は、本操作は不要です。

 

システムロケール変更で改善されなかった場合は、以下の作業を実施します。

 

Windows表示言語の変更

  1. スタートボタンをクリックし、設定(歯車マーク)をクリックします。

  2. Windowsの設定にて時刻と言語をクリックします。

  3. 言語 -> Windowsの表示言語をクリックし、English (United States)を選択します。
    *以下のように言語が表示される場合には、言語パックの追加は不要です。

  4. サインアウトの指示がでるため、はい、今すぐサインアウトしますをクリックします。

  5. 英語言語で起動されるため、Windowsの表示言語を日本語に変更します。
    スタートボタンをクリックし、設定(歯車マーク)をクリックし、Windows SettingsにてTime & Languageをクリックします。

  6. Languageをクリックし、日本語をクリックします。

  7. サインアウトを要求されるため、Yes,sign out nowをクリックします。

  8. 再起動後、文字化けが改善されているかどうか確認します。

 

文書のプロパティ


影響を受ける製品

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022

最後に公開された日付

02 12月 2022

バージョン

3

文書の種類

Solution