PowerScale: Isilon: Användning av sudo-kontot efter uppgraderingen misslyckas med "ANVÄNDAREN finns inte i sudoers-filen. Denna händelse är rapporterad." (kan korrigeras av användaren)

요약: Sudo-konton i ett begränsat antal OneFS-versioner skapades med hjälp av en lösning. När klustret uppgraderas till en OneFS-kodversion där problemet åtgärdades fungerar inte dessa sudo-konton korrekt. ...

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

Koden uppgraderades från en version av OneFS där isi_visudo fungerade inte mot en nyare version av OneFS där isi_visudo åtgärdades.

sudo konton som upprättats på en OneFS-version med en defekt isi_visudo upplevt fel med sudo efter uppgradering till en korrigerad kodversion (t.ex. v8.1.0.4). Trots sudo Kontoposter som bekräftas i /etc/mcp/override/sudoers och /usr/local/etc/sudoers—som kräver root Tillträde—sudo inte fungerade som den skulle.

Mer utdata från det icke-fungerande sudo-kontot kan se ut som följande utdata, förutom USERNAME is not in the sudoers file fel:

MYCLUSTER-13% sudo isi status
We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:
    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.
Password:
Sorry, user USERNAME is not allowed to execute '/usr/bin/isi status' as root on mycluster-13.

원인

Problemet är relaterat till OneFS-koden.

해결

Logga in som root användare, och:

  1. Använd
    isi_visudo
    och ta bort ANVÄNDARKONTOT som har ställts in för sudo. Var noga med att bara ta bort sudo konto som inte fungerar. Spara filen. 
    :wq!
  2. Använd
    isi_visudo
    och återskapa ANVÄNDARKONTOT med rätt inställningar. Spara filen.

Koduppgraderingen bör inte påverka rollerna och andra auktoriseringar. Användarkontot och lösenordet förblir oförändrade. När du har utfört stegen ovan kommer kontot att fungera igen.

해당 제품

Isilon

제품

Isilon, PowerScale OneFS
문서 속성
문서 번호: 000059475
문서 유형: Solution
마지막 수정 시간: 01 4월 2025
버전:  4
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.