VNX/Unity: Cinder-drivrutinen kräver storops med Red Hat OpenStack Platform 10 (kan korrigeras av användaren)
요약: OpenStack Cinder-drivrutinen för Block kräver Storops-paket för RED HAT 10.
이 문서는 다음에 적용됩니다.
이 문서는 다음에 적용되지 않습니다.
이 문서는 특정 제품과 관련이 없습니다.
모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.
증상
Implementera OpenStack Cinder i RedHat Enterprise 10-miljö.
Om du använder VNX Cinder-drivrutinen med Red Hat OpenStack Platform 10 resulterar det i felmeddelandet "Det gick inte att initiera drivrutinen".
Om du använder VNX Cinder-drivrutinen med Red Hat OpenStack Platform 10 resulterar det i felmeddelandet "Det gick inte att initiera drivrutinen".
원인
Med Red Hat OpenStack Platform 10 måste Dell EMC storops-biblioteket (https://github.com/emc-openstack/storops) installeras på varje värd som använder VNX Cinder-drivrutinen. Storops skapas och underhålls av Dell EMC och är ett Python-bibliotek som används för att skicka kommandon till VNX-systemet. Storops-biblioteket ingår inte i en grundläggande installation av Red Hat OpenStack Platform 10.
해결
Installera storops på varje OpenStack-värd som använder VNX Cinder-drivrutinen.
Se den senaste utgåvan med paketet "noarch" från den här platsen: https://github.com/emc-openstack/storops/releases.
Alternativt kan pip-pakethanteraren användas (t.ex. "pip install storops"). Mer information om hur du installerar Storops finns på Dell EMC GitHub-sidan: https://github.com/emc-openstack/storops
Se den senaste utgåvan med paketet "noarch" från den här platsen: https://github.com/emc-openstack/storops/releases.
Alternativt kan pip-pakethanteraren användas (t.ex. "pip install storops"). Mer information om hur du installerar Storops finns på Dell EMC GitHub-sidan: https://github.com/emc-openstack/storops
추가 정보
Red Hat är också medvetna om det här nya beroendet.
Mer information finns på Red Hats supportwebbplats: https://access.redhat.com/solutions/2888591
해당 제품
VNX/VNXe제품
Dell EMC Unity Family, VNX/VNXe문서 속성
문서 번호: 000065199
문서 유형: Solution
마지막 수정 시간: 30 5월 2024
버전: 4
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.