Avamar: Sql Backup falla con el siguiente error: "Se identificó una brecha de registro o no se encontró un respaldo completo"
요약: Avamar: Sql Backup falla con el siguiente error: "Se identificó una brecha de registro o no se encontró un respaldo completo".
이 문서는 다음에 적용됩니다.
이 문서는 다음에 적용되지 않습니다.
이 문서는 특정 제품과 관련이 없습니다.
모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.
증상
El respaldo de SQL falla aleatoriamente con un error de brecha de registro: "Se identificó una brecha de registro o no se encontró un respaldo completo".
La parte correspondiente del registro de respaldo (con depuración):
La parte correspondiente del registro de respaldo (con depuración):
2022/05/04-23:00:22.09299 [avsql_assist] called avspawnpipe::~avspawnpipe
2022/05/04-23:00:22.09299 [avsql_assist] avspawnpipe::~avspawnpipe done with avspawnpipe::wait stdout
2022/05/04-23:00:22.09299 [avsql_assist] called avspawnpipe::~avspawnpipe
2022/05/04-23:00:22.09299 [avsql_assist] avspawnpipe::~avspawnpipe done with avspawnpipe::wait stderr
2022/05/04-23:00:22.16199 [avsql_assist] xml_message::parse parse error: expected = at 000000001C8D3041 in input
2022/05/04-23:00:22.17100 [avsql_assist] ERROR: xml_message::validname('') invalid xml name
2022/05/04-23:00:22.17100 [avsql_assist] avsql_metadata::avsql_metadata sqlmetadata = '< />
'..
.
.
.
2022/05/04-23:00:22.18400 [avsql_assist] ===> avsql_assist::evaluate_backup_lsn
2022-05-04 19:00:22 avsql Warning : Evaluate backup LSN numbers is not supported in this version of metadata file (v0.000000).
2022/05/04-23:00:22.18499 [avsql_assist] sqlconnectimpl_smo::get_last_backup_lsn
2022/05/04-23:00:22.18499 [avsql_assist] retrieving last backup lsn for '' db from sys.database_recovery_status
2022/05/04-23:00:22.18499 [avsql_assist] ===> sqlconnectimpl_smo::InitDll
2022/05/04-23:00:22.18499 [avsql_assist] SMO dll already loaded.
2022/05/04-23:00:22.18600 [avsql_assist] SMOWrap::SMO_GetLastBackupLSN
2022/05/04-23:00:22.19000 [avsql_assist] database '', last backup lsn = '271000002085600001'
2022/05/04-23:00:22.19099 [avsql_assist] avsql_metadata::get
2022/05/04-23:00:22.19099 [avsql_assist] ===> avsql_metadata::get
2022/05/04-23:00:22.19099 [avsql_assist] avsql_assist::align_numeric_ustrings
2022/05/04-23:00:22.19099 [avsql_assist] Before alignment - Str1: '', Str2: '271000002085600001'
2022/05/04-23:00:22.19099 [avsql_assist] After alignment - Str1: '000000000000000000', Str2: '271000002085600001'
2022/05/04-23:00:22.19099 [avsql_assist] : A log gap was identified or a full backup was not found.
원인
El problema es analizar el archivo sqlmeta desde el respaldo incremental anterior.
La parte inferior del archivo sqlmeta (existe en system_info archivos de área: consulte la base de conocimientos 000102778 Avamar: Cómo recuperar los archivos de área de system_info desde un respaldo de Avamar
ARCHIVO TRUNCADO DE 17411017 A 16777216 BYTES ******
El archivo sqlmeta se truncó debido a la limitación de tamaño de avtar de 16 MB.
Sql Server en cuestión tiene varias bases de datos. Cada base de datos tiene varios grupos de archivos, lo que provocó que un archivo (sqlmeta) tenga más de 90 000 filas (tamaño de más de 16 MB).
La parte inferior del archivo sqlmeta (existe en system_info archivos de área: consulte la base de conocimientos 000102778 Avamar: Cómo recuperar los archivos de área de system_info desde un respaldo de Avamar
ARCHIVO TRUNCADO DE 17411017 A 16777216 BYTES ******
El archivo sqlmeta se truncó debido a la limitación de tamaño de avtar de 16 MB.
Sql Server en cuestión tiene varias bases de datos. Cada base de datos tiene varios grupos de archivos, lo que provocó que un archivo (sqlmeta) tenga más de 90 000 filas (tamaño de más de 16 MB).
해결
Para resolver el problema de Avamar: Sql Backup falla con el siguiente error: "Se identificó una brecha de registro o no se encontró un respaldo completo".
- Actualice el servidor Avamar a la siguiente versión de software.
- 19.8.100-83
- Una vez finalizada la actualización, aplique hf 338735
- Siga este artículo de la base de conocimientos para descargar el HF y recuerde leer las instrucciones del archivo LÉAME antes de aplicarlo:
해당 제품
Avamar문서 속성
문서 번호: 000201975
문서 유형: Solution
마지막 수정 시간: 15 2월 2024
버전: 4
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.