SQL Server-tjenesten (MSSQLSERVER) starter ikke

요약: Microsoft SQL Server-tjenesten (MSSQLSERVER) kan mislykkes i å starte på grunn av en skadet database. Denne artikkelen illustrerer prosessen med å feilsøke dette problemet.

이 문서는 다음에 적용됩니다. 이 문서는 다음에 적용되지 않습니다. 이 문서는 특정 제품과 관련이 없습니다. 모든 제품 버전이 이 문서에 나와 있는 것은 아닙니다.

증상

Microsoft SQL Server-tjenesten (MSSQLSERVER) starter ikke. Feil 7024 (kilde: Service Control Manager) vises i systemhendelsesloggen på serveren der SQL er installert.

원인

Denne tjenesten kan mislykkes i å starte av flere grunner, og denne artikkelen adresserer en: en skadet database.

해결

Når en tjeneste ikke starter, logger Service Control Manager en feil i systemhendelsesloggen til serveren som er vert for tjenesten. Denne hendelsen (ID 7024 i dette tilfellet) kan gi nok detaljer til å feilsøke problemet. Når du feilsøker et problem med SQL Server-tjenesten, inneholder SQL-feilloggen sannsynligvis mer nyttig informasjon.

Hvis du vil finne SQL-feilloggen, gjør du følgende:
  1. Start SQL Server Configuration Manager.
  2. Velg SQL Server Services i venstre rute.
  3. I den midterste ruten høyreklikker du SQL Server (MSSQLSERVER) og velger Egenskaper.
  4. I egenskapsvinduet velger du kategorien Oppstartsparametere .
  5. I feltet Eksisterende parametere inneholder oppføringen som begynner med -e banen til feilloggen.
I File Explorer blar du til banen gitt ovenfor. ERRORLOG-filen uten filtype er gjeldende feillogg. (ERRORLOG-filer med numeriske utvidelser er eldre logger.) Åpne gjeldende loggfil i Notisblokk, og bla til slutten av filen. Den siste oppføringen i loggen skal være en feil som angir årsaken til tjenestefeilen.

En skadet database kan angis med en feil som ligner på denne:

SQL Server oppdaget en logisk konsistensbasert I/O-feil: Feil kontrollsum

Feilmeldingen angir også hvilken database som opplevde problemet. Det kreves tre systemdatabaser for at SQL-tjenester skal starte: hoveddatabasen , modelldatabasen og tempdb. Feilen nevner sannsynligvis en av disse databasene.

Hvis skade i hoveddatabasen er årsaken, anbefales det å gjenopprette databasen fra en sikkerhetskopi.

Hvis skade i modelldatabasen er årsaken, kan du finne en reparasjonsprosedyre i Reparasjon av SQL Server-modelldatabase.

Tempdb-databasen opprettes på nytt hver gang SQL Server-tjenesten starter, så lenge modelldatabasen er intakt.

해당 제품

Prosupport for Microsoft Software
문서 속성
문서 번호: 000223030
문서 유형: Solution
마지막 수정 시간: 23 1월 2025
버전:  3
다른 Dell 사용자에게 질문에 대한 답변 찾기
지원 서비스
디바이스에 지원 서비스가 적용되는지 확인하십시오.