ECS: Deaktivieren der Objektsperrfunktion auf ECS für IBM Content Manager

Samenvatting: IBM Content Manager kann nach dem Neustart der Services nicht auf ECS 3.6.2 gestartet werden, wenn für den Bucket die Objektsperre deaktiviert ist.

Dit artikel is van toepassing op Dit artikel is niet van toepassing op Dit artikel is niet gebonden aan een specifiek product. Niet alle productversies worden in dit artikel vermeld.

Symptomen

Anwendung, die von 501 Fehlern betroffen ist. Im Folgenden wird dataheadsvc.log auf ECS beobachtet:
dataheadsvc.log.20211016-013228.gz:2021-10-16T01:04:12,908 [qtp911357121-41701] INFO RequestLog.java (line 83) 1x.xx.1xx.xx GET //test-bucket/?object-lock= HTTP/1.1 501 3 – 160

Oorzaak

ECS-Codeversion 3.6.2 Hat die Funktion "Object-lock" eingeführt, aber es gibt zwei Voraussetzungen, um die Objektsperre für Buckets auf ECS zu aktivieren:
  • Objektsperre funktioniert nicht mit ADO-aktivierten Buckets. Dies wird in 3.7.1 behoben.
  • Die Objektsperre funktioniert nicht mit Legacy-Benutzern. (Nicht-IAM-Benutzer)

Oplossing

Diese Einschränkung wirkt sich bekanntermaßen auf Anwendungen wie IBM Content Manager aus, die nach dem Start nach "?object-lock" suchen. Vor 3.6.2 wurde ECS entwickelt, um die Objektsperre zu ignorieren. Post 3.6.2 403 oder 404 Rückgabecodes werden zurückgegeben.

Ab Version 3.6.2.1 und höher kann die Objektsperre bei Bedarf mit einem Patch deaktiviert werden. In 3.7 kann die Objektsperre global deaktiviert oder für bestimmte Buckets aktiviert oder deaktiviert werden. 

Wenden Sie sich an den Dell Technologies ECS-Support, um die Objektsperre bei Bedarf zu deaktivieren.

Artikeleigenschappen
Artikelnummer: 000192958
Artikeltype: Solution
Laatst aangepast: 06 apr. 2023
Versie:  6
Vind antwoorden op uw vragen via andere Dell gebruikers
Support Services
Controleer of uw apparaat wordt gedekt door Support Services.