Decrypt Agent Does Not Follow Policy-Based Encryption Rules When Performing the Decryption Sweep

Resumo: The Decrypt Agent does not follow Policy-Based Encryption rules (policy-defined exclusions or inclusions) defined at the server when performing the decryption sweep during uninstall of Dell Encryption. ...

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Sintomas

Affected Products:

  • Dell Encryption Enterprise

Affected Operating Systems:

  • Windows

The Decrypt agent tries to sweep all data on the disk and if it encounters files that are protected, it errors with access denied messages and causes the sweep to stop and decryption to fail.

 Recursive call on <File/Folder Path> resulted in stop being requested. Exiting…

The Filefilender.log created during the Decrypt process could show the error message:

Note: The Filefilender.log can be found at C:\programdata\dell\dell data protection\encryption.
[12.21.20 10:22:17] FileSystemSweep - RecursiveSweepPath_Interruptible: SweepPath_Interruptible encountered errors processing "<File/Folder Path>".
[12.21.20 10:22:17] FileFinder - FindFirst: FindFirstFileW using pattern "\\?\<File/Folder Path>*" failed. Error 5
[12.21.20 10:22:17] FileSystemSweep - RecursiveSweepPath_Interruptible: fileFinder.Start returned false for "<File/Folder Path>". Flagging as error and exiting...
[12.21.20 10:22:17] FileSystemSweep - RecursiveSweepPath_Interruptible: recursive call on "<File/Folder Path>" resulted in stop being requested. Exiting...
[12.21.20 10:22:17] FileSystemSweep - RecursiveSweepPath_Interruptible: recursive call on "<File/Folder Path>" resulted in stop being requested. Exiting...
[12.21.20 10:22:17] FileSystemSweep - RecursiveSweepPath_Interruptible: recursive call on "C:\ProgramData" resulted in stop being requested. Exiting...
[12.21.20 10:22:17] FileSystemSweep - RecursiveSweepPath: recursive call on "C:\" indicated an error.

Causa

The Decrypt Agent attempts to sweep all files and folders on the disk and could stop decrypting if it encounters protected files or folders. In this case, a filter-level driver could prevent access to certain folders and files, which would prevent the Decrypt Agent from being able to scan those files for encryption status and decrypt them if necessary. If this occurs the Decrypt Agent never finishes processing the decrypt sweep, and the Dell Encryption drivers are not uninstalled.

Resolução

There is no remediation for this behavior. Customers wanting to decrypt endpoints must remove software that creates protected files and folders to allow the decryption to complete. Once decryption is complete, the software may be reinstalled to the endpoint.


To contact support, reference Dell Data Security International Support Phone Numbers.
Go to TechDirect to generate a technical support request online.
For additional insights and resources, join the Dell Security Community Forum.

Produtos afetados

Dell Encryption
Propriedades do artigo
Número do artigo: 000187394
Tipo de artigo: Solution
Último modificado: 07 mai. 2024
Versão:  6
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