VMware SRM을 사용하는 RecoverPoint: 페일오버 작업 실패 "쓰기 가능한 스토리지 생성" 단계

Summary: VMware SRM(Site Recovery Manager) 페일오버 또는 테스트 페일오버 작업이 "쓰기 가능한 스토리지 생성" 단계에서 잠시 후 실패합니다. 오류 - 복제본 디바이스의 스냅샷을 생성하지 못했습니다. SRA 명령 'testFailoverStart'가 실패했습니다. 사이트 관리 IP에 대한 사용자에 대한 세션을 열지 못했습니다. ...

Acest articol se aplică pentru Acest articol nu se aplică pentru Acest articol nu este legat de un produs specific. Acest articol nu acoperă toate versiunile de produs existente.

Symptoms

SRM(Site Recovery Manager) 테스트 실패로 인해 사용자는 SRM 시간 초과를 31분 이상으로 늘리고 이미지 액세스 활성화 작업이 시간 초과 설정보다 더 오래 걸립니다.

4단계에서 SRM 테스트 페일오버 또는 페일오버 작업이 실패할 수 있음: 이 단계의 일정 시간(기본값 31분)이 지나고 SRM 복구 계획 단계에서 오류가 발생하여 "쓰기 가능한 스토리지 스냅샷 생성"이 발생합니다.

Error - Failed to create snapshots of replica devices. SRA command 'testFailoverStart' failed. Failed opening session for user to site mgmt IP.

SRM 로그 오류(C:\ProgramData\VMware\VMware vCenter Site Recovery Manager\Logs명령 사용):

--> Feb 20, 2019 3:12:52 PM com.emc.santorini.log.KLogger log
--> INFO: Starting to run: TestFailoverStart command
--> Feb 20, 2019 3:43:53 PM com.emc.santorini.log.KLogger logWithException
--> WARNING: Caught SocketTimeoutException. Please check your network connection to the RPAs.
--> javax.xml.ws.WebServiceException: java.net.SocketTimeoutException: Read timed out
-->     at com.sun.xml.internal.ws.transport.http.client.HttpClientTransport.readResponseCodeAndMessage(Unknown Source)
-->     at com.sun.xml.internal.ws.transport.http.client.HttpTransportPipe.createResponsePacket(Unknown Source)
-->     at com.sun.xml.internal.ws.transport.http.client.HttpTransportPipe.process(Unknown Source)
-->     at com.sun.xml.internal.ws.transport.http.client.HttpTransportPipe.processRequest(Unknown Source)
-->     at com.sun.xml.internal.ws.transport.DeferredTransportPipe.processRequest(Unknown Source)
-->     at com.sun.xml.internal.ws.api.pipe.Fiber.__doRun(Unknown Source)
-->     at com.sun.xml.internal.ws.api.pipe.Fiber._doRun(Unknown Source)
-->     at com.sun.xml.internal.ws.api.pipe.Fiber.doRun(Unknown Source)
-->     at com.sun.xml.internal.ws.api.pipe.Fiber.runSync(Unknown Source)
-->     at com.sun.xml.internal.ws.client.Stub.process(Unknown Source)
-->     at com.sun.xml.internal.ws.client.sei.SEIStub.doProcess(Unknown Source)
-->     at com.sun.xml.internal.ws.client.sei.SyncMethodHandler.invoke(Unknown Source)
-->     at com.sun.xml.internal.ws.client.sei.SyncMethodHandler.invoke(Unknown Source)
-->     at com.sun.xml.internal.ws.client.sei.SEIStub.invoke(Unknown Source)
-->     at com.sun.proxy.$Proxy36.testFailoverStartWithOpaques(Unknown Source)
-->     at com.emc.santorini.handlers.SantoriniLogic.testFailoverStart(SantoriniLogic.java:278)
-->     at com.emc.santorini.commands.TestFailoverStartCommand.execute(TestFailoverStartCommand.java:40)
-->     at com.emc.santorini.handlers.SantoriniCommandDispatcher.handleCommandAction(SantoriniCommandDispatcher.java:105)
-->     at com.emc.santorini.main.SantoriniMain.main(SantoriniMain.java:57)
--> Caused by: java.net.SocketTimeoutException: Read timed out
...

RecoverPoint 측에 오류가 없습니다.

 

Cause

기본 SRM 시간 초과는 5분으로 설정되며 31분을 초과하면 다른 시간 초과를 늘릴 수 있습니다. 이미지 액세스 프로세스가 1860초(31분) 이상 걸리는 경우 SRA 시간 초과가 발생할 수 WEB_SERVICE_REQUEST_TIMEOUT 기본적으로 1860초로 설정됩니다.

 

Resolution

해상도:
SRM에서 요청된 시간 초과 변경 사항과 일치하도록 SRA 시간 초과를 변경합니다.
SRA 시간 초과는 SRM 서버의 다음에서 설정됩니다. C:\Program Files\VMware\VMware vCenter Site Recovery Manager\storage\sra\array-type-recoverpoint\conf\cancun_run.properties file
두 SRM 서버 모두에서 변경해야 합니다.

SRM 시간 초과(초 단위로 설정)와 일치하도록 다음 속성을 변경합니다. 이 예에서는 1시간 - 3600초로 설정됩니다.

VERIFY_PAUSED_TSP_TIMEOUT=3600
VERIFY_REPLICATING_TIMEOUT=3600
VERIFY_TRANSFER_SNAP_SHIPPING_IDLE_TIMEOUT=3600

WEB_SERVICE_REQUEST_TIMEOUT=3600
참고: 이 변경 후에는 서비스를 다시 시작할 필요가 없습니다. 다음 SRM 작업에서 새 설정이 사용됩니다.

Produse afectate

RecoverPoint

Produse

RecoverPoint, RecoverPoint CL, RecoverPoint EX, RecoverPoint SE
Proprietăți articol
Article Number: 000053724
Article Type: Solution
Ultima modificare: 21 Nov 2025
Version:  6
Găsiți răspunsuri la întrebările dvs. de la alți utilizatori Dell
Servicii de asistență
Verificați dacă dispozitivul dvs. este acoperit de serviciile de asistență.