RecoverPoint en RecoverPoint for VMs: De CLI-sessie eindigt abnormaal met het bericht "Killed" wanneer opdrachten worden uitgevoerd.

Summary: RecoverPoint: CLI-sessie eindigt abnormaal met het bericht "Gedood"; dit bericht wordt mogelijk niet weergegeven als de sessie wordt uitgevoerd via PuTTY, omdat PuTTY het venster kan sluiten. ...

Acest articol se aplică pentru Acest articol nu se aplică pentru Acest articol nu este legat de un produs specific. Acest articol nu acoperă toate versiunile de produs existente.

Symptoms

Veel gecombineerde CLI-wijzigingen in een grootschalige omgeving kunnen dit probleem veroorzaken. Het uitvoeren van opdrachten in grote omgevingen kan ertoe leiden dat CLI-sessies abnormaal worden afgesloten.

Als het venster open blijft, ziet de gebruiker mogelijk het bericht "Overleden":

Cluster1> add_replication_volume group=CG copy=Copy1 replication_set=RSet1 name=device_DEV01
Cluster1> add_replication_volume group=CG copy=Copy1 replication_set=RSet2 name=device_DEV02
Cluster1> add_replication_volume group=CG copy=Copy1 replication_set=RSet3 name=device_DEV03
 
Killed


Het volgende kan worden weergegeven in CLI-logboeken (extracted.*/files/home/kos/cli/result.xx.log):

2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: Handling command: create_replication_set
2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: In CommandHandler::handleCommand(..)
2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: In CreateReplicationSetHandler::initDataMembers()
2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: In CommandHandler::initDataMembers()
2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: m_settingsCache is relevant, returning
2018/07/29 21:32:48.614 - #2 - 11940/11940 - CLI: Calling Mgmt::getState()
2018/07/29 21:32:49.949 - #2 - 11944/11940 - MemoryShield: totalMemory = 827.188 [MB] resMemory = 331.613 [MB] shrMemory = 73.7656 [MB]
2018/07/29 21:32:49.949 - #0 - 11944/11940 - MemoryShield: errno=0 memory low watermark exceeded, current=347721728 totalMemory = 827.188 [MB] resMemory = 331.613 [MB] shrMemory = 73.7656 [MB], limit=283115520
2018/07/29 21:32:49.949 - #0 - 11944/11940 - MemoryShield: errno=0 memory high watermark exceeded, current=347721728 totalMemory = 827.188 [MB] resMemory = 331.613 [MB] shrMemory = 73.7656 [MB], limit=314572800
2018/07/29 21:32:49.949 - #0 - 11944/11940 - MemoryShield: errno=0 memory shield discovered an error !!!
2018/07/29 21:32:49.949 - #2 - 11944/11940 - DLManager: dumpDetectors
2018/07/29 21:32:49.949 - #2 - 11944/11940 - DLManager: running status for N6Kashya29MemoryShieldScheduler_AO_IMPLE, pid=11944/11940, config=(alertThreshold=10,alertLevel=0,killThreshold=7200,coreThreshold=0,full=1), deltaTime=0, cmd=N6Kashya59MemoryShieldScheduler_AO_IMPL_printStatistics_6_CmdConcreteE
2018/07/29 21:32:49.949 - #0 - 11944/11940 - MemoryShield: errno=0 Assertion failed: false Line 285 File MemoryShield.cc PID: 11940 Info: memory limit exceeded, no core
END OF LOGGER

Cause

Vanwege de grootte van de omgeving en veel wijzigingen die binnen dezelfde CLI-sessie worden gecombineerd, bereikt het CLI-proces zijn geheugenlimiet en loopt het vast.

Bij het maken van een consistentiegroep worden bijvoorbeeld veel wijzigingen gecombineerd in de edit_group_settings commando als een enkele wijziging. Een ander voorbeeld is "heavier" commando's zoals get_group_statistics.

Resolution

Oplossing:
Het volgende ondertekende script kan worden uitgevoerd op het cluster-IP met behulp van putty/ssh > , [2] Setup -> [8] Advanced options -> [4] Run script.

 

ZWE0M2YwMTIzYzg5ZWRhZjk2MzIwYzAzNzA0MzI5YzIKdW5saW1pdGVkCm5vdF9yZXN0cmljdGVk
ClRoZSBpZCBvZiB0aGUgc2NyaXB0IGlzOjAwMDE2NzExNQpDcmVhdGUgYW4gb3V0cHV0IGZpbGUg
Zm9yIGdyb3VwIHN0YXRpc3RpY3MgaW4gbGFyZ2UgZW52aXJvbm1lbnRzCk5pdiBOZXRhbmVsaQoj
IS9iaW4vY3NoCmVjaG8gZ2V0X2dyb3VwX3N0YXRpc3RpY3MgLW4gPiAvaG9tZS93d3cvaW5mby9H
cm91cF9TdGF0cy5vdXRwdXQKY2htb2QgK3IgL2hvbWUvd3d3L2luZm8vR3JvdXBfU3RhdHMub3V0
cHV0CmZvcmVhY2ggQ0cgKCBgc3UgYWRtaW4gLWMgImdldF9ncm91cHMgLW4iIHwgZWdyZXAgIl4g
IFtbOmFsbnVtOl1dIiB8IHNlZCBzLVwgXCAtLWcgfCBzZWQgcy1cOi0tZ2AgKQojICBlY2hvICRD
RwogIHN1IGFkbWluIC1jICJnZXRfZ3JvdXBfc3RhdGlzdGljcyBncm91cD0kQ0ciID4+IC9ob21l
L3d3dy9pbmZvL0dyb3VwX1N0YXRzLm91dHB1dAplbmQKc2V0ZW52IEVUSCBgZ3JlcCBldGggL2hv
bWUva29zL2NvbnRyb2wvYWNxdWlyZUlQLnRjc2ggfCBhd2sgJ3twcmludCAkN30nIHxncmVwIGV0
aGAKc2V0ZW52IElQIGBpcCBhZGQgfCBncmVwICJnbG9iYWwgJEVUSCIgfCBoZWFkIC1uMXxhd2sg
J3twcmludCAkMn0nIHwgc2VkICJzL1wvLiovLyJgCmVjaG8gR3JvdXAgU3RhdGlzdGljcyBmaWxl
IGF2YWlsYWJsZSBodHRwczovLyRJUC9pbmZvCmV4aXQgMAo=
#

Het uitvoerbestand is gemaakt op https://{RPA-IP}/info/Group_Stats.output.


Tijdelijke oplossing 2:
Er bestaat een oplossing voor dit probleem, maar hiervoor is hulp van de technische support van Dell Technologies vereist. Ondersteunend personeel moet toegang hebben tot uw Site Control-apparaten voor een interne wijziging. Neem contact op met het Dell Technologies Customer Support Center of uw servicevertegenwoordiger voor technische support en raadpleeg de ID van deze Dell Technologies Knowledge Base-oplossing.

Produse afectate

RecoverPoint, RecoverPoint CL, RecoverPoint EX, RecoverPoint for Virtual Machines

Produse

RecoverPoint SE
Proprietăți articol
Article Number: 000167115
Article Type: Solution
Ultima modificare: 16 Jan 2026
Version:  5
Găsiți răspunsuri la întrebările dvs. de la alți utilizatori Dell
Servicii de asistență
Verificați dacă dispozitivul dvs. este acoperit de serviciile de asistență.