「VPLEX:Data Mobilityによる移行が「NullPointerException: while extracting elements on property extent-migrations」エラーで失敗する

Summary: この記事では、データ移行を開始しようとしたときに発生するエラーと、この問題を回避する方法について説明します。

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Symptoms

バッチ移行または単一デバイス移行のいずれかを開始すると、次のエラー メッセージが表示されます。

> failed. cause: while extracting elements on property extent-migrations: NullPointerException

Cause

データ モビリティーの移行が失敗し、エラー メッセージが表示されます。" NullPointerException: while extracting elements on property extent-migrations"

Resolution

解像度:
この問題は、次で修正されました: GeoSynchrony 6.2 Patch 4 and later.

回避策:

移行期間中のみRestV1に切り替え、移行が完了したらRestV2に戻すことをお勧めします

V2はV1よりも高速であるため、移行が完了したらRestV2に戻す必要があります。
 

  1. 管理サーバーにログインし、ディレクトリーを変更します (cd)を /var/log/VPlex/cli
  2. ワンイン /var/log/VPlex/cli vi ファイル instance.properties をクリックし、以下の変更を行います。 


            uncomment VPlexRESTv2Enabled if there is a # symbol in front of it.
            #VPlexRESTv2Enabled=true

            Then change "true" to "false"
            VPlexRESTv2Enabled=false

           完了したら、次のように入力してVIセッションを保存して終了します。wq
 

  1. 管理コンソールを再起動します。

           sudo /etc/init.d/VplexManagementConsole restart
 

  1. 次に、移行ジョブを再実行します。
  2. 移行ジョブが完了したら、RestV1からRestV2に戻します。
  3. 管理サーバーのプロンプトから、 /var/log/VPlex/cli/ ディレクトリ cd をそれに追加します。
  4. いったん /var/log/VPlex/cli ディレクトリ、vi instance.properties ファイルを次のように作成します。


           変更 VPlexRESTEnabled false から true へ。

            変更前:
            VPlexRESTv2Enabled=false

            この行を次のように変更します。
            VPlexRESTv2Enabled=true

            編集が完了したら、次のように入力してviセッションを保存して終了します。wq
 

  1. 管理コンソールを再起動します。


           sudo /etc/init.d/VplexManagementConsole restart
 

Produse afectate

VPLEX Series, VPLEX VS2, VPLEX VS6
Proprietăți articol
Article Number: 000183825
Article Type: Solution
Ultima modificare: 15 Jan 2026
Version:  4
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