PowerFlex 3.x: Der SDS-Service weist kontinuierlich Fehler bei der Funktion drl_IsClean

Summary: In seltenen Fällen kann es beim SDS-Service zu einem kontinuierlichen Fehler mit der Funktion drl_IsClean. Dieses Problem tritt auf, wenn die SDS-Geräte größer als 2 TB sind.

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Symptoms

Beim SDS-Service tritt kontinuierlich ein Fehler mit dem folgenden Stack Trace auf:

/opt/emc/scaleio/sds/logs/exp.0

2024/07/22 21:54:33.819866 Panic in file /data/build/workspace/ScaleIO-Common-Job/src/tgt/bm/drl.c, line 1238, function drl_IsClean, PID 17253.Panic Expression !(offsetInLbs < pDrl->protectedOffsetInLbs) PANIC_ID_tgt_1497349762194.
/opt/emc/scaleio/sds/bin/sds-3.6.400.107(mosDbg_PanicPrepare+0x13a) [0x93ab8a]
/opt/emc/scaleio/sds/bin/sds-3.6.400.107(drl_IsClean+0x5e) [0x9346ae]
/opt/emc/scaleio/sds/bin/sds-3.6.400.107(mgPhyDev_IsDrlGroupClean+0x4b) [0x93476b]
/opt/emc/scaleio/sds/bin/sds-3.6.400.107(mgPhyComb_ReadIntegrityBits+0x130) [0x906040]
/opt/emc/scaleio/sds/bin/sds-3.6.400.107(mgStorageRegion_ReadRegionIntegrity+0xb4) [0x906224]
/opt/emc/scaleio/sds/bin/sds-3.6.400.107(storageRegion_ReadDirtyRegion+0xad) [0x740f4d]
/opt/emc/scaleio/sds/bin/sds-3.6.400.107(raidComb_ReadDrl+0x7d) [0x74105d]
/opt/emc/scaleio/sds/bin/sds-3.6.400.107(ioh_ReadCombDrl+0x758) [0x5eb368]
/opt/emc/scaleio/sds/bin/sds-3.6.400.107(ioh_NewRequest+0x2084) [0x5fb4a4]
/opt/emc/scaleio/sds/bin/sds-3.6.400.107(contNet_RecvIORequest+0x2c4) [0x601534]

 

Auswirkungen 

Die Nichtverfügbarkeit von Nutzerdaten kann auftreten, wenn ein anderer SDS entkoppelt wird, da er sich in einem der folgenden Status befindet:

  • Sofortiger Wartungsmodus (IMM)
  • Fehlerstatus
  • Während einer laufenden Neuerstellung

Cause

 

SDS-Servicefehler, die durch große Geräte-Offsets verursacht werden.

 

Resolution

Fehlerbehebung:

  • PowerFlex 3.6.5 und höher (Ende des Supports)
  • PowerFlex 4.5 und höher

 

Problemumgehung:

Befolgen Sie eine der Optionen.
Wenn das Problem durch Option 1 nicht behoben werden kann, fahren Sie mit Option 2 fort.

 

Option 1:

    • Geben Sie den SDS-Node über die SCLI-Befehlszeile oder die Benutzeroberfläche des Präsentationsservers in den IMM ein.
      • Wenn der SDS-Node nicht in den IMM wechseln kann, beenden Sie den SDS-Daemon, indem Sie das Skript ausführen /opt/emc/scaleio/sds/bin/delete_service.sh.
        Take necessary precautions to prevent the cluster from entering a Data Unavailability (DU) state. Before stopping the SDS daemon, verify that no Rebuild is in progress.
        If you're unsure about the DU state, consult L2 or an SME.
    • Beenden Sie den SDS-Service, sobald der SDS im IMM platziert wurde. 
      /opt/emc/scaleio/sds/bin/delete_service.sh
    • Entfernen Sie den gemeinsam genutzten Speicher auf dem SDS (einschließlich CloudLink Shared Memory). 
      • Verschieben Sie die mit dem folgenden Befehl erzeugten Dateien in ein temporäres Verzeichnis
        ls -l /dev/shm | egrep -i *EMC_sds*
        ls -l /dev/shm | egrep emc_scaleio_*
         
         
    • Starten Sie den SDS-Service
      /opt/emc/scaleio/sds/bin/create_service.sh
  •  
    • Beenden Sie den SDS über die SCLI oder die Benutzeroberfläche des Präsentationsservers aus dem IMM. Es wird erwartet, dass ein erneuter Aufbau beginnt. Wenn sich der SDS nicht im IMM befand, fahren Sie mit dem nächsten Schritt fort 
       
    • Überprüfen Sie die Ausgabe des folgenden Befehls, um sicherzustellen, dass der SDS verbunden ist:
      scli --query_all_sds


    Option 2: 

    • Wenn sich das System nicht im Status "Datenfehler" befindet und ausreichend freie oder Reservekapazität verfügbar ist, entfernen Sie den SDS-Node aus dem PowerFlex-Cluster. Sobald die Neuverteilung abgeschlossen ist, fügen Sie den SDS-Node mit allen SDS-Geräten erneut hinzu.

     

    WICHTIG:
    Background Scanner (BGS) und Partial Device Error (PDE) können möglicherweise dazu führen, dass das Problem erneut auftritt. Deaktivieren Sie BGS, wenn möglich, oder verwenden Sie BGS im Modus "Nur Bericht".
    Persistente Prüfsummen sollten keine Probleme auslösen. Wenn jedoch eine nicht übereinstimmende Prüfsumme vorliegt, wird ein geringfügiger Neuaufbau initiiert, wodurch das Problem erneut auftreten kann. Deaktivieren Sie nach Möglichkeit die persistente Prüfsumme.

    Produse afectate

    PowerFlex Software

    Produse

    PowerFlex Appliance
    Proprietăți articol
    Article Number: 000228035
    Article Type: Solution
    Ultima modificare: 08 Jul 2025
    Version:  9
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