PowerFlex 4.6 Varios pods se reinician una y otra vez

Summary: Varios pods se siguen reiniciando durante y después de una nueva implementación o actualización a 4.6.1 de un grupo de recursos (RG) de solo almacenamiento (SO) y solo computación (CO). ...

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Symptoms

Nueva implementación de PowerFlex Manager 4.6.1 o actualización a 4.6.1 con 200+ nodos de SO y CO 

En la vista de pantalla durante el reinicio, se muestra una falta de memoria: 

lack_of_memory 

Impacto

  • Estado inestable del sistema y la interfaz de usuario deja de responder o no está disponible

Cause

Debido a un problema de software en las versiones 4.6.1 y superiores de PowerFlex Manager Platform (PFMP), los sistemas con más de 200 nodos (tanto SO como CO) requieren más recursos informáticos que los anunciados anteriormente: 28 núcleos de CPU y 64 GB de memoria.

Resolution

Procedimiento de apagado

  1. Inicie sesión en un MVM y ejecute los siguientes comandos para detener la base de datos:
    1. Valide el estado de la base de datos:
      kubectl config set-context default --namespace=$(kubectl get pods -A | grep -m 1 -E 'platform|pgo|helmrepo|docker' | cut -d' ' -f1)
       
      echo $(kubectl get pods -l="postgres-operator.crunchydata.com/control-plane=pgo" --no-headers -o name && kubectl get pods -l="postgres-operator.crunchydata.com/instance" --no-headers -o name) | xargs kubectl get -o wide
       
      kubectl -n powerflex patch $(kubectl -n powerflex get postgrescluster -o name) --type merge --patch '{"spec":{"shutdown":true}}'
       
       
    2. Valide que la base de datos esté apagada:
      echo $(kubectl get pods -l="postgres-operator.crunchydata.com/control-plane=pgo" --no-headers -o name && kubectl get pods -l="postgres-operator.crunchydata.com/instance" --no-headers -o name) | xargs kubectl get -o wide
      
       
       
  2. Apague el MVM

 

Actualizar recursos de MVM

Para implementaciones nuevas o actualizaciones a 4.6.1, los nodos MVM tendrían que cumplir con los requisitos adicionales de memoria y CPU:

  • CPU: 28 núcleos
  • Memoria: 64 GB
Para conocer el procedimiento completo sobre la adición de recursos, póngase en contacto con el proveedor.

 

Procedimiento de encendido

  1. Encienda todos los MVM
     
  2. En cada MVM, ejecute el siguiente comando para comprobar el estado del servicio rke2-server:
    kubectl get nodes
    
     
     
    Realice lo siguiente según el estado del servidor rke2:

    Estado del servidor rke2

    Realice lo siguiente

    Activo

    Ir al paso siguiente

    Activador

    Repita el comando para comprobar el estado del servidor rke2 hasta que esté activo.

    Fracasado

    Intente iniciar el servicio mediante la ejecución del siguiente comando:

    systemctl start rke2-server
    
     
  3. Una vez que el servidor rke2 esté activo en todos los MVM, asegúrese de que todos los nodos estén en un estado listo:
    kubectl get nodes
    
     
     
  4.  Una vez que los nodos estén listos, vaya al paso siguiente. Si aparece un mensaje de error, espere unos minutos y vuelva a intentarlo.
    1. Restaure la base de datos del operador de monitoreo de clústeres (CMO):
      kubectl config set-context default --namespace=$(kubectl get pods -A | grep -m 1 -E 'platform|pgo|helmrepo|docker' | cut -d' ' -f1)
       
      kubectl -n powerflex patch $(kubectl -n powerflex get postgrescluster -o name) --type merge --patch '{"spec":{"shutdown": false}}'
       
       
    2. Verifique la base de datos de CMO:
      echo $(kubectl get pods -l="postgres-operator.crunchydata.com/control-plane=pgo" --no-headers -o name && kubectl get pods -l="postgres-operator.crunchydata.com/instance" --no-headers -o name) | xargs kubectl get -o wide
      
       
       
  5. Monitoree el estado de la plataforma de administración de PowerFlex:
    1. Ejecute el siguiente comando para identificar el número de puerto de la utilidad del monitor de la plataforma de administración de PowerFlex:
      kubectl get services monitor-app -n powerflex -o jsonpath="{.spec.ports[0].nodePort}{\"\n\"}"
      
       
       
    2. Espere entre 20 y 30 minutos y compruebe el estado general de la plataforma de administración de PowerFlex.
       
  6. Vaya a http://< node IP>:p ort/, donde la dirección IP del nodo es una dirección IP de administración configurada en cualquiera de los MVM (no la dirección IP de Ingress o PowerFlex Manager).
     
  7. Haga clic en Estado de PFMP y espere a que todas las entradas se vuelvan verdes.
     
  8. Ahora se podrá acceder a la interfaz de usuario principal de PFMP (a veces puede esperar de 20 a 30 minutos).

 

Versiones afectadas

PFMP 4.6.1

Problema corregido en la versión

PFMP 4.8

Produse afectate

PowerFlex appliance R650, Powerflex appliance R750

Produse

PowerFlex rack, PowerFlex appliance connectivity, PowerFlex appliance R760, PowerFlex custom node
Proprietăți articol
Article Number: 000321671
Article Type: Solution
Ultima modificare: 31 Jul 2025
Version:  5
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