Los pods de nodos PowerFlex de CSM se bloquean en init:0/2
Summary: Módulos de almacenamiento de contenedores (CSM) Los pods de nodos de PowerFlex se bloquean en init:0/2 después de que se reiniciaron los hosts debido a algunos cambios aplicados a ellos. ...
Symptoms
Todos los pods de nodos de PowerFlex están atascados en init:0/2 y error informado "Warning FailedMount 8s (x6 over 23s) kubelet MountVolume.SetUp failed for volume "scaleio-path-bin" : mkdir /bin/emc: read-only file system " en la descripción del pod.
El problema se produjo con el operador de CSM 1.9 y 1.8.1 con el controlador de la interfaz de almacenamiento de contenedores (CSI) para PowerFlex 2.13.1 y 2.14.
Cause
La causa raíz de este problema es que el operador de CSM no puede determinar si se está ejecutando en un entorno OpenShift durante la inicialización. Almacena en caché esa información para su uso posterior. Es probable que, en el momento del inicio del operador, el siguiente comando no haya devuelto el resultado esperado:
oc get --raw /apis | jq | grep "security.openshift.io"
Esto sugiere que el security.openshift.io Es posible que el grupo de interfaz de programación de aplicaciones (API) no estuviera disponible en ese momento.
En el registro del operador, si ve [isOpenShift err false], significa que el operador no puede determinar el entorno OpenShift.
2025-06-17T08:45:38.167Z INFO workspace/main.go:99 isOpenShift err false {"TraceId": "main"}2025-06-17T08:45:38.168Z INFO workspace/main.go:105 Kubernetes environment {"TraceId": "main"}
El mensaje de registro correcto para determinar el entorno OpenShift es:
2025-06-19T00:03:14.913Z INFO workspace/main.go:138 Openshift environment {"TraceId": "main"}
Resolution
- Ejecute manualmente el siguiente comando:
oc get --raw /apis | jq | grep "security.openshift.io"
and
oc auth can-i get /apis/security.openshift.io --as=system:serviceaccount:dell-csm-operator:dell-csm-operator-manager-service-account
- El resultado esperado es
# oc get --raw /apis | jq | grep "security.openshift.io" "name": "security.openshift.io", "groupVersion": "security.openshift.io/v1", "groupVersion": "security.openshift.io/v1",
# oc auth can-i get /apis/security.openshift.io --as=system:serviceaccount:dell-csm-operator:dell-csm-operator-manager-service-accountyes
3. Si ve el resultado anterior, reinicie el operador de CSM:
oc delete pod dell-csm-operator-controller-manager-xxx-xxx -n openshift-operators
4. Si el resultado no es el mismo que el anterior, solicite al cliente que se comunique con el soporte de Red Hat para realizar una verificación más detallada.