CSM PowerFlex -solmun podit ovat juuttuneet kohtaan init:0/2
Summary: Säilötallennusmoduulit (CSM) PowerFlex-solmujen podit juuttuvat kohtaan init:0/2 sen jälkeen, kun isännät on käynnistetty uudelleen niihin tehtyjen muutosten vuoksi.
Symptoms
Kaikki PowerFlex-solmujen podit ovat jumissa init:0/2 ja ilmoitettu virhe "Warning FailedMount 8s (x6 over 23s) kubelet MountVolume.SetUp failed for volume "scaleio-path-bin" : mkdir /bin/emc: read-only file system " podin kuvauksessa.
Ongelma ilmeni CSM Operator 1.9- ja 1.8.1 with Container Storage Interface (CSI) -ohjaimen kanssa PowerFlex-versioissa 2.13.1 ja 2.14.
Cause
Ongelman perimmäinen syy on se, että CSM-operaattori ei pysty määrittämään, onko se käynnissä OpenShift-ympäristössä alustuksen aikana. Se tallentaa nämä tiedot välimuistiin myöhempää käyttöä varten. On todennäköistä, että operaattorin käynnistyshetkellä seuraava komento ei palauttanut odotettua tulosta:
oc get --raw /apis | jq | grep "security.openshift.io"
Tämä viittaa siihen, että security.openshift.io Application Programming Interface (API) -ryhmä ei ehkä ole ollut käytettävissä sillä hetkellä.
Jos operaattorilokissa on [isOpenShift err false], se tarkoittaa, että operaattori ei pysty määrittämään OpenShift-ympäristöä.
2025-06-17T08:45:38.167Z INFO workspace/main.go:99 isOpenShift err false {"TraceId": "main"}2025-06-17T08:45:38.168Z INFO workspace/main.go:105 Kubernetes environment {"TraceId": "main"}
Oikea lokiviesti OpenShift-ympäristön määrittämiseksi on:
2025-06-19T00:03:14.913Z INFO workspace/main.go:138 Openshift environment {"TraceId": "main"}
Resolution
- Suorita seuraava komento manuaalisesti:
oc get --raw /apis | jq | grep "security.openshift.io"
and
oc auth can-i get /apis/security.openshift.io --as=system:serviceaccount:dell-csm-operator:dell-csm-operator-manager-service-account
- Odotettu tulos on
# oc get --raw /apis | jq | grep "security.openshift.io" "name": "security.openshift.io", "groupVersion": "security.openshift.io/v1", "groupVersion": "security.openshift.io/v1",
# oc auth can-i get /apis/security.openshift.io --as=system:serviceaccount:dell-csm-operator:dell-csm-operator-manager-service-accountyes
3. Jos tulos näkyy yllä, käynnistä CSM-operaattori uudelleen:
oc delete pod dell-csm-operator-controller-manager-xxx-xxx -n openshift-operators
4. Jos tulos ei ole sama kuin yllä, pyydä asiakasta ottamaan yhteyttä Red Hat -tukeen ja tarkistamaan tilanne.